This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 3 voices.

Last updated by Yvette 1 year ago.

Assigned support staff: Yvette.

Author Posts
September 24, 2018 at 10:31 pm

Fernando

I am trying to: copy once every custom field i created when translating posts.

Link to a page where the issue can be seen: admin page

I expected to see: when i click on the copy content from, all fields with contents, like the orignal language.

Instead, I got: nothing, no fields, no texts...

September 26, 2018 at 1:08 am #2765412

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us.

Have you checked our documentation on how to synchronize custom fields? If not, you can see the steps in our documentation: https://wpml.org/documentation/getting-started-guide/translating-custom-fields/

Basically, at the end of the pages, you can select the "Copy Once" option on the "Multilingual Content Setup" and click Save. Then just update the translation page and the content should be copied correctly.

Also, the "Copy Once" option will not synchronize after it has already been saved. That is, if you have already saved this page previously, this option will no longer be copied.

If the problem persists, please could you post an example of which page the problem is going through, plus which fields do you want to copy?

Thank you.

September 26, 2018 at 1:30 am #2765417

Fernando

Hi, i did follow every tutorial, steps, available in the internet, the problem is here:

"Basically, at the end of the pages, you can select the "Copy Once" option on the "Multilingual Content Setup" and click Save. Then just update the translation page and the content should be copied correctly."

It does not sabe the option "Copy Once", is there a limit to the amount of ACF fields?

September 26, 2018 at 12:02 pm #2767098

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Bruno has taken holiday so I will be helping you going forward.

You wrote: "It does not sabe the option "Copy Once", is there a limit to the amount of ACF fields?"

To my knowledge there is no known limit, but with ACF fields, you also need to be sure that corresponding "hidden" fields are also set to be copied. Did you do this?

e.g. if you have an ACF field "window" then you will also find a system field "_window" . Both of these custom fields need to have the translation options set.

You also wrote: "..I expected to see: when i click on the copy content from, all fields with contents, like the orignal language..."

To move faster, could you please provide a specific example and steps to replicate the error so I can confirm the problem?

Thanks

September 26, 2018 at 1:14 pm #2767390

Fernando

Hi, i did not know about the hidden fields, i tried to save them as well with no success. I have a lot of ACF fields, more them a hundred, i click all of them do "copy once", but after saving and reloading the page, some of them return to "don't translate".

I believe the problem with no being copied was related to the hidden fields, i could not test it because they are not saving to "copy once" as mentioned above.

The attached image shows some fields i click to copy once, after saving, and reloading the page, tey return to do not translate.

September 27, 2018 at 5:38 am #2769338

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I see.

Please provide a sample page where you need these fields to copy and they are not.

I should also explain the "copy once" means that the custom field will be created in the translated post and initially filled with the value from the orinigal language.

After that - there is no more synchronisation/automatic update.

I wait for the page/post link.

September 27, 2018 at 11:10 am #2770245

Fernando

Hi,

A created a copy from one post for testing purposes, it's a complete example.
hidden link

I understand the copy once, and that's exactly what i need.

Thanks

September 27, 2018 at 2:25 pm #2770839

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I see that you have not translated your Field Groups...and that the configuration for this post type is set to "Do not translate".

This is most likely your error.

Please review the following documentation in the order they are listed:
hidden link
https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

You need to set the "Field Group" post type to be translatable. Then you need to duplciate/edit independently the field groups to each target language.

After doing this, then please check if the "copy once" is working or not.

September 27, 2018 at 7:55 pm #2771708

Fernando

Do you realize that those are two different methods of translating the content right?
It's hugely confusing, the link you sent is for a new method ("Field Group" is set to not translate) that i tested today, and the pictures are for the "old way" ("Field Group" is set to translatable).

As i said, i've tried all possible solutions, enabling/disabling different plugins like ACFML, Translation Manager, saving all options as both methods, the problem that i still have is, the FIELD, when i set the option to be translatable, or copy once, it does not save, neither in the WPML » Settings page, nor inside the Post itself at the bottom where i can set which fields i want to be translatable.

I think the problem is somewhere else not related to ACF

September 27, 2018 at 8:26 pm #2771751

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Have you ever translated the Field Group?

My experience with ACF is that the Field Group must be duplicated to all translated languages. I am not aware that there are 2 ways to do things.

We can clear this up by creating a simple field group with a simple field and then seeing if the field will copy. Do you mind if I do this?

September 27, 2018 at 8:33 pm #2771756

Fernando

You sent me the second method: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/

Yes i have translated before with ACF and worked, needed some setup as well, but worked, with the "old" method.

Yes, you can create a field and a post but don't make it public.

September 27, 2018 at 10:09 pm #2771928

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I am still not clear what you mean by new and old methods. I do see in the ACF documentation that in newer versions, you will not see the post type "Fields" in the multilinguagl content setup but the image they wrote includes the "Fields" type. However, it does say clearly that you have to have the "Fields Group" set to "Translate".

I tried creating a new Field Group called WPML with one text field called "wpml". However, I do not see it being listed in the available fields in the list of custom fields available to translate. I then see that you have a beta version of WPML ACF bridge plugin.

I have taken a duplicator clone of your site and will be working locally to have more freedom.

September 27, 2018 at 11:34 pm #2771947

Fernando

I attached an image from the link you provided, showing that in this link, "Field Groups" is set to "do not translate", different from what is explained in the ACF page.

I tested the version 0.9 of ACFML to see if it would work the functionality of changing automatically the selection of all subfields.

"However, I do not see it being listed in the available fields in the list of custom fields available to translate. I then see that you have a beta version of WPML ACF bridge plugin." That is the problem, no updates, no new fields, no changes at all

September 28, 2018 at 6:41 am #2772694

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I see now. This *is* confusing.

I´ll work off of the local server copy of your site so I can work faster and update you with my observations/findings/questions.

Thanks for your patience in the meantime.

September 30, 2018 at 11:28 am #2776441

Fernando

Thanks, will be waiting for an update.

The topic ‘[Closed] WPML configuration to copy once is not saving the options i select’ is closed to new replies.