This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by Lauren 1 month, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
April 20, 2019 at 2:24 am #3648775

chenbiaoZ

I am trying to: Fix the WMPM compatibility issue

Link to a page where the issue can be seen: hidden link

I expected to see: AMP is valid

Instead, I got: Not a valid AMP page

PS: I submit a ticket before, but still didn't fix it, please check it here:
https://wpml.org/forums/topic/after-install-wmpl-our-amp-is-disappeared-and-this-leads-to-traffic-decrease/

I did what he asked, including:

1. Update all the related components that are involved in this issue.
A. Update WordPress to its latest version (currently 5.1.1 and you are using 4.9.10) and see if the issue persists.
B. We have just released new versions for WPML and its add-ons, so please also update WPML at this opportunity. Check if the issue persists.
C. Update your theme the Soledad theme. It is on version 5.2, and version 6.3.1 is available. While you are updating the theme please also check if the PenCi Soledad AMP add-on of the theme has a new version.
2. Deactivate all the third party plugins and leaving active only WPML and its add-ons and the PenCi Soledad AMP plugin.

But it still doesn't work!

April 22, 2019 at 5:44 pm #3657559

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

It sounds like there is a compatibility issue between your theme and WPML. To confirm this, I have created a staging site. Please install the theme and AMP plugin so that we can try and reproduce the issue here:
Login: hidden link
Username: demo
Password: Z8RlB59w4Ylm

Let me know once you have installed the theme and I will continue troubleshooting there. Thanks!

April 23, 2019 at 3:56 am #3659575

chenbiaoZ

Hi Lauren, I installed the theme and AMP plugin. Please check it. Thanks!

April 24, 2019 at 1:09 am #3668031

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for installing that for me. I tested by just changing the header color in the Customizer AMP settings, and it seems to be working correctly. Can you please check the settings and have them match your live site settings so that I can try and reproduce the issue? The page I tested was the homepage hidden link

April 24, 2019 at 2:50 am #3668661

chenbiaoZ

Hi Lauren,

1. Where did you revise the code? Can you show us a screenshot? We provide a screenshot, is that the place you mean?
2. If that is, I am afraid we can't change the color as you set in AMP customizer. And we don't think that is not the problem. Color is really not the problem that causes the compatibility issue.
3. I found our blog homepage AMP works, but other posts' AMP page doesn't work.
hidden link
4. Please kindly look into the problem. Thanks.

April 24, 2019 at 6:08 pm #3675809

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Yes, I changed the color there just to test and see if the changes took place. I also found that on my test site, when you change permalinks to post name, it works just fine on posts as well as on the homepage. Please see this example: hidden link

Can you please try changing the permalinks on your site to see if this resolves the issue?

April 26, 2019 at 1:13 am #3686505

chenbiaoZ

Hi, as I mentioned before, I tested and only found our blog homepage's AMP valid. But our other posts' AMP is not valid.

Original page: hidden link
AMP Page: hidden link

"I also found that on my test site, when you change permalinks to post name, it works just fine on posts as well as on the homepage."
--- I don't think this is the reason that causes the compatibility issue! Even it is, it is impossible for us or others to change permalinks to post name!

And I don't mean to offend you, but I found you are NOT professional towards this problem, according to your two replies.

I strongly suggest you forward this problem to your technical department or someone who are professional in such kind of issues.

Thanks!

April 26, 2019 at 3:00 pm #3691743

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Please see my previous private reply and let me know once the migration is completed so that our team can further troubleshoot. Thanks!

April 27, 2019 at 2:38 pm #3695513

chenbiaoZ

Hi there,

Thank you for your information. But when I try to migrate the site, it shows error "Unable to execute PHP file on the site. Please check with your hosting provider."

And under this error, it asks me to enter a lot more other information as shown in the screenshot.

Please check what should I enter for those I mark Red Box.

Thank you!

April 29, 2019 at 2:01 pm #3704133

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I'm sorry that the migration did not work for you, seems like Cloudways is having some problems this past weekend.

As an alternate option, please send me a copy of your site and I can set it up locally for further testing. You can use the Duplicator plugin or All in One Migration plugin to send me a snapshot of your site. Then I can set it up locally. I have set the next reply as private so that you can share the links to download the files. Thank you for your cooperation.

The topic ‘[Closed] WPML conflict with AMP’ is closed to new replies.