This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 21 replies, has 3 voices.

Last updated by vivekP 6 days, 21 hours ago.

Assigned support staff: Bigul.

Author Posts
July 19, 2019 at 1:59 pm #4246873

heidiS-6

I am trying to: Filter the list of posts / pages in Translation Management to show "All" instead of just "Pages" (so I can see my Gravity Forms to translate them). I am on a Pantheon site.

Link to a page where the issue can be seen: this is in the backend of a development website so there is not a link.

I expected to see: The list of translatable content switch to "All types" instead of "Pages"

Instead, I got: When the Filter button is clicked, the selection resets back to "Pages" no matter what option is chosen.

I have contacted Pantheon regarding this and they notified me that the cookies that WPML uses are incompatible with Pantheon. Pantheon requires cookies to have a special "cache-busting" format that WPML does not have. WPML cookies need to be made compatible with Pantheon in order for this to work.

July 19, 2019 at 6:00 pm #4247787

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please visit WPML>>Languages>>Language filtering for AJAX operations and make sure is there any difference in the result when *Store a language cookie to support language filtering for AJAX* option is enabled or disabled?

Are you getting the expected when you choose *Post* other Post Types instead of *Page*?

--
Thanks!

Bigul

July 19, 2019 at 7:38 pm #4248033

heidiS-6

Changing *Store a language cookie to support language filtering for AJAX* doesn't seem to help. No matter what I select, it goes back to page. So "Post" doesn't work either.

July 20, 2019 at 9:01 am #4249437

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please share with me the WordPress debug.log (not WPML debug information) for more details.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

July 22, 2019 at 1:55 pm #4258135

heidiS-6

Here is the debug log: https://pastebin.com/Z9EBjbxp

I don't know how helpful this is, it appears to be showing an unrelated error.

July 22, 2019 at 5:55 pm #4260571

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the Debug log details. As you mentioned it is not showing any warning or error related to WPML. So please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

--
Thanks!

Bigul

July 22, 2019 at 6:34 pm #4260787

heidiS-6

I did all of those things, and it still doesn't work.

I was told initially by Pantheon (our host) that the WPML cookies aren't compatible with Pantheon hosting. Is that something you can look into?

July 23, 2019 at 6:21 am #4262885

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please fill the private details fields after a full site backup. I would like to access the admin area of your site for further checking.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Also please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

July 23, 2019 at 5:30 pm #4268467

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and login information. I will check about this with our second tier team and get back to you soon. Please wait.

--
Thanks!

Bigul

July 25, 2019 at 9:15 am #4281233

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

We have a request. Please check is it possible for setting a cookie for the whole *wp-admin*(WordPress Dashboard). Maybe it will help us to solve the issue.

hidden link

Please try it and let me know your feedback.

--
Thanks!

Bigul

July 25, 2019 at 12:54 pm #4283285

vivekP

Following this issue to see what the resolution ends up being. I also have a client hosted on Pantheon who uses WPML who isn't able to filter their translations due to cookies not being handled correctly because of Pantheon's caching requirements.

Based on the Varnish config docs @ hidden link
renaming the cookies to have a prefix of "STYXKEY", "wordpress" or "wp-" should work in telling Varnish not to cache those page requests.

July 25, 2019 at 1:48 pm #4283717

heidiS-6

Sent this back to Pantheon to see if the request was possible and they told us that the only way this can be fixed is for WPML to be modified to conform to their standards: "Varnish configuration is immutable so the only way here is to adjust the plugin based on the pattern the platform requires."

July 26, 2019 at 8:40 am #4288431

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have shared it with the our team. We will get back to you soon. Please wait.

Have you got any feedback from Pantheon team?

--
Thanks!

Bigul

July 26, 2019 at 12:28 pm #4289617

heidiS-6

Yes, as I said above, Pantheon responded and said that the solution to this problem is for WPML to use cookies that conform to their standards.

July 29, 2019 at 6:19 am #4297135

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I am escalating the ticket to our second tier team for further checking. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul