This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am getting an error that says "WPML could not load configuration files, which your site needs." on my plugins page. Solution: Usually, this is a temporary connection issue. If the issue keeps happening on the site, please try the following steps: 1. Clear all the cache. 2. Try registering WPML if needed 3. Check if there is some option to block external connections in the Wordfence Security plugin. 4. Ask the hosting service support if there is some firewall rule preventing your site to access this address: cdn.wpml.org

100% of people find this useful.

This topic contains 8 replies, has 4 voices.

Last updated by Vincenzo 11 months, 4 weeks ago.

Assigned support staff: Vincenzo.

Author Posts
July 5, 2018 at 9:19 am #2466402

Jorge Marcos Fernández

I am getting an error that says "WPML could not load configuration files, which your site needs." on my plugins page. When I click on "detailed error log", it takes me to the "Remote XML Config Log" and suggests that I retry, but all I get is a message telling me to show you the error details. The "Details" table says:
request: get_option
type: app_error
component: wpml_config_files_arr
response: Missing data

Also, I'm trying to register my site with my account and it never seems to do so. After introducing the code correctly, the message still appears.

July 5, 2018 at 10:07 am #2466640

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

Usually, this is a temporary connection issue.
I just tested on my server but I am not able to reproduce it.

If the issue is still happening on your site, please try the following steps:

1. Clear all the cache.

2. Try registering WPML

3. Check if there is some option to block external connections in the Wordfence Security plugin.

4. Ask the hosting service support if there is some firewall rule preventing your site to access this address: cdn.wpml.org

Thank you

July 5, 2018 at 10:26 am #2466713

Jorge Marcos Fernández

I have tried that which you have recommended, plus even restarting the Apache service. I haven't seen anything weird in the Wordfence plugin, and have certainly not changed its settings recently. No external connections are being blocked, confirmed. My Avada theme can connect externally without a problem. Sorry. Thanks for your help

July 5, 2018 at 11:00 am #2466889

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

from what I can see, your site is registered with the http:// prefix on our site.
See: https://wpml.org/account/sites/

Can you please remove the old registration from our site and from your site and add a new one with the https:// prefix?
You can do it from Plugins -> Add New -> Commercial

Please let me know if this solves the issue or if you need further details.

Thank you

July 5, 2018 at 12:02 pm #2467156

Jorge Marcos Fernández

Thank you, I guess that was it. It actually solved all my problems somehow.

September 5, 2018 at 8:57 pm #2708730

scottL-10

I did above, still see errors:

Insert your key and activate automatic updates, I got:

cURL error 28: Resolving timed out after 10519 milliseconds

September 6, 2018 at 8:32 am #2710001

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

@scottl-10

Try these steps:

- Go to Dashboard -> Updates
- Press the "Check Again" button
- Press the "Update" button at the bottom of the page

- Go to Plugins -> Add New -> Commercial
- Press the "Check for updates" button

- Go to https://wpml.org/account/sites/ look for your current key and erase it.
- Create a new one for your site.
- Go to Plugins -> Add New -> Commercial
- Click on the "Unregister WPML from this site" button
- Register WPML adding your new key.
- Try also disabling the "Keep wpml.org up-to-date about which theme and plugins I use" option

If that does not fix the issue, please open a new ticket.
You can do it from here: https://wpml.org/forums/forum/english-support/
This helps us to bring you a better service

Thank you

October 26, 2018 at 4:03 pm #2853618

gracielaA

hi, i,ve tried everything you suggest here but still when i try to go to Plugins-> add new -> Commercial ... nothing happens,, just a blank page

October 26, 2018 at 4:07 pm #2853622

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

@gracielaa

This ticket is closed. May I ask you to open a new ticket?
You can do it from here: https://wpml.org/forums/forum/english-support/
This helps us to bring you a better service

Thank you