This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 6 months ago.

Assigned support staff: Itamar.

Author Posts
April 16, 2019 at 11:54 am #3621677

foteiniG

Hello ,

When installing WPML, there are the following errors:

supplied for foreach() in\sitepress-multilingual-cms\vendor\otgs\installer\includes\class-wp-installer.php on line 677

Warning: Invalid argument supplied for foreach() in \sitepress-multilingual-cms\vendor\otgs\installer\includes\class-otgs-installer-plugin-finder.php on line 26

Warning: Invalid argument supplied for foreach() in \sitepress-multilingual-cms\vendor\otgs\installer\includes\repository\class-otgs-installer-repositories.php on line 54
and many warnings

Also,WPML could not load configuration files, which your site needs.

Under construction website

April 16, 2019 at 7:06 pm #3624989

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I want to check a few things on your site.
Could you please give me access to your site?

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

April 19, 2019 at 7:29 am #3643843

foteiniG

Hello,
I continue to get the same errors. Unfortunately, access is difficult to be given at this time on the website because it is under construction and it is hosted on a server with access only via Local Network. I have requested. Could you please help me with these errors?

April 21, 2019 at 7:02 pm #3652877

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

You mentioned that your site is hosted on a server with access only via Local Network, and I suspect that this is the very reason that you are having this problem. The server that your site is hosted on or a proxy server that is between your server and the internet are blocking the loading of the load configuration files.

If you want, I can set up a test server on our server where you can migrate your site to, and there hopefully this problem wouldn't happen. Or on our test server, if needed, we can debug the issue properly. Please let me know if you want me to set up a test server for you.

Regards,
Itamar.

April 23, 2019 at 8:23 am #3660553

foteiniG

Dear Itamar,
Thank you for your quick answer.
Could you please set up a test server on your server to migrate the site and check it?
Best Regards,
Foteini

April 23, 2019 at 8:45 pm #3667585

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Foteini.

Please see the next private message with all the details on how to migrate your site to our test server.

Thanks,
Itamar.

The topic ‘[Closed] WPML could not load configuration files, which your site needs.’ is closed to new replies.