This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 8 voices.

Last updated by capie 5 years, 10 months ago.

Assigned support staff: sarah.n.

Author Posts
October 24, 2013 at 7:24 am #281551

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Rich,

This is exactly the problem, we can't replicate this particular problem on our installations. Is it completely out of the question to be given temporary access to your installation?

I truly want to help. Especially because I was also involved in some other tickets reporting this issue It bothers me that I could not get to the bottom of it so I would like another chance to investigate this further.

October 24, 2013 at 6:47 pm #281955

Richard

Ok. I've given you temp access.

I created a new admin login for you and I repro'd the bug using that login.

Please, if you save a post, make sure to uncheck the Post to Facebook checkbox if it is checked before saving (it's next to the update button).

Steps to repro.

Go to WPML translation UI.
Do a search to find an old post where translation is complete.
Select that post to edit the English version.
Uncheck the "Post to Facebook" if necessary.
Click update button.

Rich

October 25, 2013 at 7:43 pm #282436

Ivica

I didn't saw this before. I have exact same problem. Just to keep informed.

October 28, 2013 at 9:28 am #282886

Cristi

I get the exact same set of errors except my warning shows up for line 918 instead of 929 of file translation-management.class.php.

foreach($job->elements as $element){

I have WPML Multilingual CMS 2.8.2 and Worpdress 3.6.1. Will update both soon but would prefer to find out more about the problem here. I'm not using String Translation if that matters.

October 28, 2013 at 1:19 pm #283115

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Richard,

Apologies for the delay! I will run a test as soon as possible and get back to you.

October 29, 2013 at 9:30 am #283534

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Richard,

I've tested a couple of old posts using the steps you provided. I got the error only in some of them and only the first time I updated the original. The second time I would update the same document (I would hit the back button to return to the previous screen) the error did appear. This was consistently so. Can you please confirm this is the case with you too?

Also, the error that I got was this:

Warning: Invalid argument supplied for foreach() in [...]/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php on line 2022

I managed to download a copy of your database and I will try to replicate locally so our developers have a way to troubleshoot this further.

October 30, 2013 at 10:33 pm #284622

Richard

Hi Sarah,

I think you made a typo in your last post?

>The second time I would update the same document (I would hit the back button to return to >the previous screen) the error did appear.

I think you meant, did NOT appear????

I tried again just now, and I only get the error the first time I try and edit the post. If I go and edit it again, then I get no error.

Maybe this is do to the fact that when I first edit the post, the WPML status is "Translation Complete".

The second time, you edit, the status is "Needs updating"???

Just a guess.

I'm not sure why the line numbers of the stacktrace have changed since I first opened this thread, but I'm getting what you are getting now.

Warning: Invalid argument supplied for foreach() in ..../plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php on line 2022

Warning: Invalid argument supplied for foreach() in ..../plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php on line 2022

Warning: Cannot modify header information - headers already sent by (output started at ..../plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php:2022) in ..../wp-admin/post.php on line 222

Warning: Cannot modify header information - headers already sent by (output started at ..../plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php:2022) in ..../wp-includes/pluggable.php on line 899

October 31, 2013 at 6:41 am #284660

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Indeed! It was a typo. Sorry about that 🙂

I have a test copy of your site now live and just like it was with all the other users I had in previous tickets. The problem no longer appears!

I can give you access if you like but I've tested a number of older posts. Nothing! They all save just fine.

Could you do me a favour? If I email you the sql dump I downloaded from your db, could you import it on a test environment and test again? See if you also get the issue resolved like this. Would you be willing to try?

November 1, 2013 at 9:29 pm #285687

Richard

Hi Sarah,

Sorry, I don't have the test environment or the bandwidth to do this.

I am going to try and disable my W3 Total Cache and see if that make a difference.

I've already had to disable the Database Cache as that caused problems with comments.

I'm still using the Object Cache though. This is just a shot in the dark though.

Does your test environment have W3 TC installed?

Rich

November 4, 2013 at 7:14 am #286074

sarah.n
Supporter

Languages: English (English ) German (Deutsch )

Richard, you asked: "Does your test environment have W3 TC installed?"

No, it does not. It has WPML, WPML String Translation and WPML Translation Management.
I am also using the WordPress default theme.

Like I said, I can give you access to the site. Just let me know.

November 20, 2013 at 11:01 am #295289

Johan

Any update on this issue? I am getting the same error:

Warning: Invalid argument supplied for foreach() in /home/user/domains/domain.nl/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php on line 2023

Warning: Invalid argument supplied for foreach() in /home/user/domains/domain.nl/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php on line 2023

Warning: Cannot modify header information - headers already sent by (output started at /home/user/domains/domain.nl/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php:2023) in /home/user/domains/domain.nl/public_html/wp-admin/post.php on line 222

Warning: Cannot modify header information - headers already sent by (output started at /home/user/domains/domain.nl/public_html/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php:2023) in /home/user/domains/domain.nl/public_html/wp-includes/pluggable.php on line 899

December 3, 2013 at 3:45 pm #301685

capie

Hi, Any updates? I have exactly the same errors here reported.

The topic ‘[Closed] WPML Crash when editing a published post that has translations’ is closed to new replies.