Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Bruno Kos 1 month, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
February 27, 2021 at 1:51 pm

ivayloI

I installed WPML on my site hidden link, but when I run it, it crashes in some kind of way. I will send you the WP admin info, so you can log in and try

February 27, 2021 at 3:25 pm
March 1, 2021 at 7:33 am #8193717

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I am not sure it is about redirect - first thing I noticed is that language directories are not working at all.

Even in other languages, it hits 404 (I duplicated the original home page for testing)
hidden link
hidden link

But I see that directories are not functioning at all, while parameters options also change url in other languages improperly.

Can you see with your host about these errors from the image? Let me only check if "URL rewriting is not enabled in your web server.", others seems to be valid.

Regards,
Bruno Kos

language url rewriting.jpg
March 2, 2021 at 7:26 am #8204041

ivayloI

Hello,
I have this rerouting
<link rel="alternate" hreflang="en" href="/%hidden link" />
<link rel="alternate" hreflang="ru" href="/%hidden link" />
<link rel="alternate" hreflang="ro" href="/%hidden link" />
And my website is loading

hidden link
instead of hidden link. My hosting provider did the following things:
- all resources load as https
- no 301 redirects
- no caching plugin to mess things up

I think it is some setting in the plugin. But I can't find it. Any ideas?

March 2, 2021 at 11:07 am #8206557

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

There is no such setting in WPML that would cause these problems and broken URLs.

Can I ask you the following? In order to debug this issue, I will install Duplicator plugin, will create packages and will try this on my localhost and possibly escalate further to 2nd tier.

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

Regards,
Bruno Kos

March 2, 2021 at 11:26 am #8206769

ivayloI

Yes, no problem.

March 2, 2021 at 12:33 pm #8207627

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I restored the site on my localhost and see how things work by default without changing anything:
hidden link

So there is a setting (or set of settings) on your server which prevents normal functioning of any URL which is not default - meaning of any translated URLs, either directories or parameters.

As far as I see the backend is also affected - if you try checking the URLs of any translations of the homepage, you will find that it shows the wrong one - it doesn't show the language parameter.

I suggest you do this:
- create a subdomain or even subfolder
- restore duplicator package there
- see if the problem is still persistent, as that may exclude specific server config or caching

Because it is obviously a configuration problem on the server-side, something hosting support company should have a better look at.

Regards,
Bruno Kos

wrong url in the backend as well.jpg
March 3, 2021 at 3:38 pm #8219501

ivayloI

The problem was from the permalinks. Now it is okay.

On the English version hidden link when I open on mobile Explore the mysterious world of
TRUFFLES - goes to Bulgarian, but only this text. Any ideas why is that?

March 4, 2021 at 7:15 am #8224357

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It looks like that this is coming from here, so this mobile phone part wherever set is not yet translated.

Regards,
Bruno Kos

this for phone not translated.jpg