This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 4 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 29, 2019 at 2:31 pm

alessioC-7

I am trying to:

Link to a page where the issue can be seen: english homepage doesn't work cause wpml create a folder /en conflicting wpml creating link.

I delete this folder in my file manager but afte 1/2 days wpml create the folder again.
Other languages are ok.

I expected to see:english home page.

Instead, I got: error page.

How can I solve?

Thanks
Alessio

May 30, 2019 at 5:35 pm #3925461

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It is really weird the creation of a physical directory on the server’s drive as WPML only creates virtual directories when using the language in directories url format. Please, let me know some more details:

1 - Is there any specific event that made it happens? For example a plugin update, third party plugin install.

2 - Is there any server specific setting you tried and then the directory creation began to happen?

4 - Does it happen if you temporary try another language url format from your WordPress Dashboard > WPML > Languages settings?

Please, let me know, so we can understand this issue better. Have a nice day.

June 6, 2019 at 6:12 pm #3971435

alessioC-7

Hello,

the folder appears every 1-2 days in automatic. Nothing event or action happens is is correlate.

I can't understand why it happens.

Thanks

June 6, 2019 at 8:09 pm #3971911

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case a further look in your filesystem and error logs is needed in order to understand the cause of your issue. For that, I kindly ask you some FTP access details, I will enable a private reply, so you can safely send it. Thank you for your collaboration, have a nice day.

June 7, 2019 at 3:26 pm
June 7, 2019 at 8:03 pm #3978905

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. Can you please, tell me if the additional directory is created in the root folder of your WordPress installation? This I see so far I believe could contribute for this issue:

1 - You have a bunch of plugins adding extra rules for your .htaccess file.

2 - You have a bunch of extra files and directories not common for a standard WordPress insallation. See: https://codex.wordpress.org/WordPress_Files

I recommend you to try a stagging copy of your website in your host, this way you can run several tests, such as:

1 - Create a new standard .htaccess file and see if the issue keeps happening. See: https://wordpress.org/support/article/using-permalinks/#creating-and-editing-htaccess

2 - Keep all the plugins disabled and make sure only WPML related plugins are activated.

Please, let me know if it helps. Have a nice day.