This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I changed our website to SSL and now getting the following errors.

[Warning] [blocked] The page at https://riderspalace.com/ was not allowed to run insecure content from http://riderspalace.com/cms/wp-content/plugins/sitepress-multilingual-cms/templates/language-switchers/legacy-list-horizontal/style.css?ver=1. (riderspalace.com, line 1)

Solution:
Please delete this folder, that would help:

/wp-content/cache/wpml

0% of people find this useful.

Tagged: 

This topic contains 4 replies, has 4 voices.

Last updated by benjaminM-26 2 years, 9 months ago.

Assigned support staff: Dat Hoang.

Author Posts
January 4, 2017 at 1:24 am #1173887

joerga-3

Hi there, changed our website to SSL and now getting the following errors.

[Warning] [blocked] The page at hidden link was not allowed to run insecure content from hidden link. (riderspalace.com, line 1)

[Warning] [blocked] The page at hidden link was not allowed to run insecure content from hidden link. (riderspalace.com, line 1)

[Warning] [blocked] The page at hidden link was not allowed to run insecure content from hidden link. (riderspalace.com, line 3)

[Warning] [blocked] The page at hidden link was not allowed to run insecure content from hidden link. (riderspalace.com, line 5)

How can I change it from http to https?

January 4, 2017 at 7:45 am #1173996

Dat Hoang

Can you please delete this cache folder?

/wp-content/cache/wpml

Does that help?

January 4, 2017 at 10:34 pm #1174833

joerga-3

Hey!
Thanks a lot for your help! This seems to have done the trick.

Cheers
Joerg

February 8, 2017 at 1:14 pm #1202975

Florian Wiethoff

same problem here
in my wp-content/ there's no such dir cache/wpml/

October 24, 2018 at 9:57 pm #2847934

benjaminM-26

Just want to bump this solution that worked for me October, 2018...

https://wpml.org/forums/topic/https-error-with-templateslanguage-switcherslegacy-list-horizontalstyle-css/#post-1272555

I found about 20 different examples of people reporting similar issues. I went down the rabbit hole of serialized arrays in the DB, and all sorts of rabbit holes. This needs to be marked as a solution and referenced on the rest of the support threads with this issue.

1) Check the home and site URLs to make sure they are set to https://
2) De-activate and re-activate the plugin

I had already done an extensive search and replace and cleared all caches on my particular instance.