Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Multicurrency selector is not working on products tabs in Woodmart theme

Solution: As a workaround, add the following code to functions.php file

add_filter( 'wcml_multi_currency_ajax_actions', function( $actions ) {
  $actions[] = 'woodmart_get_products_shortcode';
  $actions[] = 'woodmart_get_products_tab_shortcode';

  return $actions;
} );

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 22 replies, has 2 voices.

Last updated by Carlos Rojas 7 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 3, 2020 at 9:31 pm #6287509

John

Hey Carlos,
Thanks for the code but unfortunately the issue still persists.
The code is added to functions.php in theme child and if I go to other tabs the price is shown on default currency.
Thanks again for your support

June 4, 2020 at 1:33 pm #6294655

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi John.

I'm consulting our compatibility specialists about this issue. I will get back to you as soon as I have an answer.

Regards,
Carlos

June 16, 2020 at 6:47 am #6379929

John

Hello, do you have any updates? Many thanks

June 16, 2020 at 9:31 am #6381367

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi,

Our compatibility specialists are working on it. I will get back to you as soon as I get an answer from them.

Regards,
Carlos

June 17, 2020 at 10:17 am #6392437

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

This is a slightly different issue, but our specialists updated the code and they already added it to the functions.php file. Now you can see that the issue is solved.

Could you confirm that the issue is solved?

Note: If you find a new issue I kindly ask you to open a new ticket and explain it there, this way we will be following our forum's rule of having one issue per ticket. It will also help future clients to find solutions to similar problems while searching on the forum.

Best regards,
Carlos

June 17, 2020 at 11:43 am #6393505

John

Hello Carlos thanks for update. Can you please share the link where the stage website?
Because the old one doesn't work anymore.
Or can you share the code that goes to function?
Thanks

June 17, 2020 at 11:49 am #6393519

John

My issue is resolved now. Thank you Carlos and the support team that helped me solved this issue.
Please post the code as a fix for other customer that had same issue in the past.
Many thanks again

June 17, 2020 at 12:26 pm #6393917

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos