If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by Raja Mohammed 6 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
April 9, 2019 at 11:29 am #3566087

romanJ-4

hi,
when default language is Lithuanian and adding new property, wpml cuts off part from domain name and displayed as hidden link. not hidden link, as you can see there is no lt at the end

April 9, 2019 at 12:11 pm #3566583

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

HI there,

Welcome to our forum,

- Please disable WPML and check whether the issue persists, Disabling WPML will not cause any data loss.

- Goto Dashboard > Settings > General, Please check both the WordPress URL and site URL are same if there is any abnormality please fix it.

If you are still stuck, Please provide temporary access to the site. I have enabled private reply for you to securely share the details.

Kind regards
Raja

April 10, 2019 at 4:41 am #3572373

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the details, I can confirm the login works.

I have checked the backed, I am unable to reproduce the error.

Is it happening when the property is added from the front end? Please let me know the steps to reproduce the error.

Kind regards
Raja

April 10, 2019 at 5:11 am #3572451

romanJ-4

hi,
I made video for you, how I get this error, please take a look in this link hidden link

April 10, 2019 at 1:53 pm #3576955

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the video, I have tried your steps but I am unable to access the URL hidden link from the profile tab and none of the links in that page works for me.

I have created a video => hidden link

Please let me know if there any restriction. I would like to take a copy of your site , You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

I have enabled the private reply for you to securely share the link.
If you are not sure how you create duplicator package, please install the plugin i can create the package.

Kind regards
Raja

April 13, 2019 at 6:19 am #3603663

romanJ-4

hi,
I fixed links in profile tab, please try again

April 15, 2019 at 6:07 am #3609907

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Thanks for the update, I am able to reproduce the issue.

I see that you have installed WPML Multilingual cms but String translation and Translation management is not available.

Please manually upload a fresh copy of WPML plugin and its add-ons, follow the below steps
Backup your site and database

- Unregister WPML from the site, go to: Plugins >> Add New Plugin >> Commercial Tab >> Unregister WPML from this site

- After that remove the keys for this site in your WPML Account

- Deactivate the existing WPML plugin and add-ons.

- Delete the plugin files – this does not delete your translations. You will just delete the plugin files from your "wp-content/plugins" folder, all your data will be kept saved.

- Upload a fresh Copy of WPML downloaded from https://wpml.org/account/downloads/

- Again register WPML in your site and enter the new key:
Please Login to your WPML account >> go to Sites page >> Remove your current site / domain from there >> and re-add your site >> it will give you New key which you can add back in your site:

Make sure you can now install String translation and translation management plugins. If you have any caching plugin or server cache try disabling them.

please let me know if you still have the issue, I will clone your site to one of our private server for a detailed debugging.

Kind regards
Raja

April 15, 2019 at 11:23 am #3612991

romanJ-4

hi,
I did steps, how you said but problem not disappear, I still have same problem

April 15, 2019 at 12:24 pm #3613411

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I would request you to migrate the site to our private server. I have sent the details regarding the migration in my previous private reply.

Kind regards
Raja

April 22, 2019 at 1:47 pm #3656195

romanJ-4

did you see that I made a migration?

April 23, 2019 at 5:49 am #3659693

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I'm checking this now,
I am unable to reproduce the issue in the cloned version I'm trying to reproduce the issue with a similar domain with .lt extension. I will update you with my findings soon.

Unfortunately, we don't receive any notification for a completed migration hence we request our clients to inform us once the migration is complete.

Kind regards
Raja

April 23, 2019 at 12:56 pm #3664115

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I am unable to reproduce the issue when I tried with dummy .lt domain in my localhost. I have requested second tier supporters for help. I will update you once I hear from them,

I have noticed WPML String translation and Translation management plugin is still missing in your setup please refer to my earlier reply https://wpml.org/forums/topic/wpml-cust-off-domain-name/#post-3609907 upload the missing plugin.

Kind regards
Raja

April 26, 2019 at 5:00 am #3687783

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have checked your site again Could you please install the missing plugin mentioned in my previous response?

We have also released the latest version of WPML and its add-ons, Please update the plugins

Recommended: Secure a backup of your site</storng>

Kind regards
Raja

April 28, 2019 at 1:16 pm #3698125

romanJ-4

to use these plugins I need to upgrade plan, but I don't need it. I resolved issue by my way, I just added /lt/ category to default language and then system works fine.

April 29, 2019 at 8:48 am #3701221

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Glad your issue is solved,

However, without a directory for default language option, the domain should be working without any issue.

If you are okay with the current setup then I think the issue can be closed.

Kind regards
Raja