This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Strange strings with numerals showing after migration of site and activating WPML String Translation

Solution: There was a known compatibility issue between Duplicator and WordPress 4.8.3 - https://wordpress.org/support/topic/percent-sign-gets-hashed-due-to-update-in-esc_sql-in-wordpress-4-8-3/

Please try to migrate again creating a new package using an updated version of the Duplicator plugin.

If it was not the case and while another supporter takes personal charge of your situation please give us more info about the migration process.

Let us know if it helps.

Relevant Documentation:https://toolset.com/faq/how-do-i-migrate-a-wordpress-site-from-one-domain-to-the-other/

This topic contains 16 replies, has 3 voices.

Last updated by Rainer 1 year, 10 months ago.

Assigned support staff: Bobby.

Author Posts
November 9, 2017 at 6:13 pm #1426414

Rainer

I am trying to: change the language

Link to a page where the issue can be seen: no language switch possible

I expected to see: a language switcher

Instead, I got: only the german flag

November 9, 2017 at 7:34 pm #1426503

Rainer

I deleted the WPML cache and cleaner up (in WPML -> Support). After that the language switcher was away.

November 10, 2017 at 10:04 am #1426797

Rainer

I started a backup, now the language switcher is visible. But the old problem after changing the hoster is back, when I activate the WPML plugin string translation, I get a lot of numbers in the backend.

November 10, 2017 at 10:25 am #1426817

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello there,

Welcome to WPML support forum.

While one of my teammates takes care of your case can you please tell me if you used the Duplicator plugin to make the migration?

There was a known compatibility issue between Duplicator and WordPress 4.8.3
- https://wordpress.org/support/topic/percent-sign-gets-hashed-due-to-update-in-esc_sql-in-wordpress-4-8-3/

Please try to migrate again creating a new package using an updated version of the Duplicator plugin.

If it was not the case and while another supporter takes personal charge of your situation please give us more info about the migration process.

Let us know if it helps.

Related documentation:
https://toolset.com/faq/how-do-i-migrate-a-wordpress-site-from-one-domain-to-the-other/

November 10, 2017 at 11:07 am #1426880

Rainer

Thanks for the info. But I didn´t want to spend more time in this issue. I delete the plugin and install it new but this was not successful.
Do you think it is possible to wait for a solution?
Because I have the problem only with 5-20 strings.
I have time to wait for a solution.
Regards Rainer

November 13, 2017 at 7:42 am #1428500

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Rainer,

If possible please confirm if you have used the duplicator plugin to load your site using a backup.

I would need to see the detail of the error log. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

November 16, 2017 at 6:52 pm #1433153

Rainer

The link to the debug log for you
hidden link
Regards Rainer

November 16, 2017 at 7:09 pm #1433170

Rainer

Hello Bobby,
I hope the information from the two posts is helpful for you to help me!
Regards Rainer

November 16, 2017 at 7:23 pm #1433182

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the debug.

I would like to understand one thing regarding this error and your set up at the moment.

I am currious to know...Was your site recently migrated ? Also did you recently use a duplicator backup to revert your site ? (not if you created a package but instead if you used a duplicator package to revert your site)

I will be enabling a private field to take a closer look to your site but Please review my questions above and answer them, This information is vital for me to continue with the debuging process

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

November 17, 2017 at 9:15 am #1433539

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you !

Were you able to try to migrate again creating a new package using an updated version of the Duplicator plugin.

Therefore upgrading the duplicator plugin in your local or previous enviroment and then creating a new package and with the new package migrating again.

This should resolve the issue.

November 17, 2017 at 2:14 pm #1434008

Rainer

Hello,
today I can make a new backup from hidden link with the duplicator plugin (actual version 1.2.30) and migrate it into the same installation.
Do you really know it´s successful?
I didn´t can do it with the old "homepage" because I changed the hosting company.
Regards
Rainer

November 17, 2017 at 5:52 pm #1434283

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If you just make a backup from the current site hidden link that is currently showing this is issue, i dont think this will resolve the issue.

You need to re-migrate your site from the staging environment or previous environment.

Is there no staging site or local environment or previous backup that you might have available?

November 21, 2017 at 10:19 pm #1437593

Rainer

Hello Bobby,
I made a backup from the current site hidden link that is currently showing this issue. I migrate it, but it doesn´t resolve the problem. You are right.

I moved the Domain and the hosting from Strato to one.com.
The old data is on the strato server (not deleted) but the domain is moved. I have no old backup.
How can I solve my problem?
Rainer
PS. if it it possible to delete the old strings and install fresh strings I can do the string translation again (only 20-30 strings)

November 22, 2017 at 7:56 pm #1438635

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Your duplicator file was corrupted.. Re backing up the site using the new duplicator plugin will not change the issue as the site is already corrupted.

The best possible option would be to get the old data from the strato server and re migrate the clean database.

the other options would be

1. Contact duplicator plugin in case they have a way to deal with corrupted and broken packages

2. Go to your database and manually replace the strings being added.
I did a quick search of the string {8596ef7d504da7bc8d76d2fff904a23aa280bd4995337dc5368bf8bc58a88ee3} in your database and it seems that the wp_icl_strings and wp_icl_string_translations tables are corrupted with this string found within them from the migration. [reason why this is happening when activating WPML]

Also it is found within wp_options as well.

I recommend manually fixing the wp_options table

and then if you do not mind losing your translations as you mentioned above you can try to drop the wp_icl_strings and wp_icl_string_translations tables and then re populate them.

To repopulate them you can use the following script found here from a seperate problem
=>https://wpml.org/errata/missing-_icl_strings-_icl_string_translations-data-tables/

NOTE* Dropping database tables and working with the database overall can be a difficult task and it is not my recommendation but please make sure you have a backup before doing so to make sure you are covered in case something does not work as planned.

Again option 1 would be best but option 2 should work ok.

November 27, 2017 at 3:53 pm #1442562

Rainer

Hello Bobby,
I discussed with Strato and it was possible to make a backup from the old data.
I migrated the old database to the new hoster one.com. I think it was successful !!!!
Please check it for me.
Regards
Rainer
PS. is it possible/useful to clean old WPML folder, cache, .... witch folder can I delete?