Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 12, 2019 at 6:54 pm #4383327

larsS-4

Site replicated as per instructions.

BR
Lars

August 12, 2019 at 9:38 pm #4383753

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Lars,

The cause of the issue is that the posts in SV that appear at the begging of the blog in English are set as sticky. If you go to Posts -> Filter by posts in SV -> Use the 'Quick edit' option -> Deselect the 'Make this post sticky' option -> Click Save.

This will fix the issue.

Could you confirm that the issue is solved?

Regards,
Carlos

August 13, 2019 at 6:50 am #4385379

larsS-4

Yes, removing the Sticky made the SV post disappear from the EN blog.
However, this does not resolve the issue. I do use Sticky for current news. It is a recent thing that SV Sticky posts get listed in the EN blog and that would need to be resolved.

Regards,
Lars

August 13, 2019 at 9:40 am #4386731

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Lars,

I tried to reproduce the issue in a fresh new WordPress install and everything looks correctly, sticky posts are only shown in their languages. You can see the test site using this link: hidden link

This means that the cause of the issue might be in the active theme of your site. Please visit this link and follow the steps described to solve the issue: https://wpml.org/forums/topic/sticky-posts-are-showing-up-on-other-languages/

Regards,
Carlos

August 16, 2019 at 6:10 am #4404825

larsS-4

I have tried it with my current Enfold theme, TwentySeventeen and TwentyNineteen.
Adding 'suppress_filters' => false, to index.php did nothing as well.
Regards,
Lars

August 16, 2019 at 6:11 am #4404827

larsS-4

I did find a work around until this is sorted and it is to hide all Sticky posts on the EN blog.

August 16, 2019 at 12:17 pm #4406219

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I'm glad to hear that your found a work around for this issue.

I recommend you to contact the authors of Enfold theme and let them know about this issue. They should be able to find a fix for this issue.

Regards,
Carlos