This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

WPML does not show proper language in WP-admin area. As soon as you switch language with the WP flag on top the language of the WPML menue and screens get messed up. I've seen all the other language or the other language mixed with English.

Solution:

uncheck the option 'Set admin language as editing language.' from Users > Your profile page

This topic contains 2 replies, has 2 voices.

Last updated by thorsetenM 4 months, 3 weeks ago.

Assigned support staff: Dennis.

Author Posts
May 22, 2019 at 4:36 am

thorsetenM

I am trying to:
always have English as language in WP-admin area. I configured it in my profile, as you can see in the screen shot, but as soon as you switch language with the WP flag on top the language of the WPML menue and screens get messed up. I've seen all the other language or the other language mixed with English.

Link to a page where the issue can be seen:
hidden link

I expected to see:
I just want everything in the admin area to stay in English.

Instead, I got:
mixed up languages

May 22, 2019 at 4:48 am #3860947

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please try to uncheck the option 'Set admin language as editing language.' from Users > Your profile page?

Does it help? Please let me know.

Kind regards,
Dennis

May 22, 2019 at 8:38 am #3863135

thorsetenM

My issue is resolved now. Thank you!