Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Andreas W. 3 weeks ago.

Assigned support staff: Andreas W..

Author Posts
November 4, 2019 at 10:33 am #4879785

marcoB-102

I am trying to: Finish translations of WPML gravity forms which use conditionals. I am aware of the value issue and have corrected that by hand, however if i hit 100% translation and want to save the gravity form, the save and leave process does not end and is therefore not successful.

Furthermore some of the checkboxes are mixed up (two choices that follow immediately after one another in german are merged in english although they should not be (one has different monetary value the other is solely informational for my client on an organisational level.

Link to a page where the issue can be seen:

beachvolleycamps.ch
hidden link
hidden link

The two Radio elements being mixed are «Spielstärke/Level» and «Reiseversicherung» which in english would be «Game Strength/Level» and «Travel Insurance»

The issue about forms not being finished is only seen in backend translation queue obviously.

Thanks for helping out on this.

November 5, 2019 at 10:57 pm #4894121

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum?

Do I understand right that the translation issue only appears on the backend? As far I can see the form is translated correctly on Front-End.

As far I can see this might be related to Gravity Forms Product Add-ons. This plugin is currently running through compatibility tests with WPML.

Could you please install the plugins on the following test site and see if you experience the same issue here? If so, we are handling another compatibility issue.

One-Click Login:hidden link

Let me know about the outcome.

Kind regards
Andreas

November 6, 2019 at 9:32 am #4896279

marcoB-102

Hi,
I've tried installing to that site however the page key is not valid anymore. I would need the gravity forms multilingual addon to find the forms in the translation manager. I've installed the rest of the required plugins and uploaded the forms for a trial run.

Thanks so far.

November 6, 2019 at 3:18 pm #4899877

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I have installed now GFML on the test-site. Could you please recreate a similar form as the one with the issue on your live site and let me know if you experience the same issue.

In case the issue does not persist on a new install, please try to test your live site in a minimal setup.

Disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to test if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.
More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

November 6, 2019 at 3:53 pm #4900035

marcoB-102

Hi,
Thanks for your reply. I know about deactivating themes and plugins. I have run the debugggin mode and found no php issue at first glance but will try again if when i get to it.

I redid the form and couldn't repeat the error.

I can now save at 100% on the live page and the translation appears as finished but the error remains.

I will get to debugging and plugin work again.

November 6, 2019 at 4:24 pm #4900267

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better for a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

November 11, 2019 at 9:31 pm #4928279

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I was asking for FTP access only in order to activate wp-debug. If the option is active already I will not need access.

I was going to connect in order to create a copy with DUplicator for debugging, but the username seems not to be valid.

Can you verify and confirm, please?

Kind regards
Andreas

November 13, 2019 at 3:35 am #4935543

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

We do currently have issues with Gravity Forms fields that are using conditional logic. We discovered the issue on dropdowns but in your case the issue seems more complex.

Sadly, it seems there has not been any debug-log file created for your site, but I will try to take a copy of the site tomorrow and escalate the issue as soon I have a detailed report about the issue.

I hope for your understanding.

Kind regards

November 14, 2019 at 3:08 pm #4948097

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Did you recognize that the issue occurred when a special element is used or is it possibly a random issue? If the issue might be random please try to duplicate the form and translate it again to see if the issue persists.

Also, please install Gravity Form on the following test site and try to recreate the issue, as I need to determine if we are handling a general compatibility issue or a problem that only occurs on your site.

One-Click Login: hidden link

Further, if the issue does not occur on a new install, I will need to take a copy of the site for further debugging.

Kind regards
Andreas

The topic ‘[Closed] WPML does not sucessfully translate content from Gravity forms’ is closed to new replies.