This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by maurizioB-11 3 months, 2 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
July 9, 2019 at 7:40 am

maurizioB-11

I am trying to: translate strings from italian (default language) to other languages

Link to a page where the issue can be seen: hidden link

I expected to see: "iva esclusa" -> "vat excluded" and "richiedi preventivo" -> "get a quote"

July 9, 2019 at 8:06 am #4168323

maurizioB-11

and i have also this error when i try to save the product in spanish:

Dettagli dell'errore
====================
Un errore di E_ERROR è stato causato nella linea 348 del file /var/www/vhosts/optikascience.com/httpdocs/optikascience/wp-content/plugins/woocommerce-multilingual/inc/translation-editor/class-wcml-synchronize-product-data.php. Messaggio di errore: Uncaught Error: Call to a member function get_stock_managed_by_id() on boolean in /var/www/vhosts/optikascience.com/httpdocs/optikascience/wp-content/plugins/woocommerce-multilingual/inc/translation-editor/class-wcml-synchronize-product-data.php:348
Stack trace:
#0 /var/www/vhosts/optikascience.com/httpdocs/optikascience/wp-content/plugins/woocommerce-multilingual/inc/translation-editor/class-wcml-synchronize-product-data.php(332): WCML_Synchronize_Product_Data->update_stock_value(false, NULL)
#1 /var/www/vhosts/optikascience.com/httpdocs/optikascience/wp-content/plugins/woocommerce-multilingual/inc/translation-editor/class-wcml-synchronize-product-data.php(172): WCML_Synchronize_Product_Data->sync_product_stock(Object(WC_Product_Simple), false)
#2 /var/www/vhosts/optikascience.com/httpdocs/optikascience/wp-content/plugins/woocommerce-multilingual/inc/translation-editor/class-wcml-synchronize-product-data.php(132): WCML_Synchronize_Product_Data->sync_product_data(154844, '154848', 'es')
#3 /var/www/vhosts/opt

July 9, 2019 at 9:42 am #4169221

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me if you have any of the of following:
- staging site
- caching enabled on this live site

The reason I am asking is because I was not able to reproduce some of these issues my localhost. Have a look at these images - since I see all these strings in the string translation table and they appear to be translated there, I'm suspecting that this might be a caching issue or something related and would like us to try some things. It will be better if we had either Duplicator package to test locally or having a staging website for testing purposes.

Let me know!

Regards,
Bruno Kos

July 9, 2019 at 9:50 am #4169377

maurizioB-11

hi,

thanks for your replay, i've no cache or similar.

can you access my wp installation and try to add a new product (default language is italian) and traslate it in en.
it's not a live site, we are working on it.
let me know
best regards

July 9, 2019 at 10:05 am #4169457

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you please check if this issue appears when:

- only WPML plugins are activated along with WooCommerce, as it will tell us if there is an interaction issue with other plugin
- theme is set to a WordPress default like Twenty Nineteen as it will tell us if there is an interaction issue with your theme

Why am I asking this? I see that you have over 60 plugins activated, some of them being Wordfence Security and Sucuri Security, possibly causing some (or all) of these issues.

Please make a full backup of this site before testing it this way, but since no caching is being used here as you confirmed, we need to see if there is compatibility issue with any of other plugins or some of the plugins settings.

Regards,
Bruno Kos

July 9, 2019 at 10:13 am #4169611

maurizioB-11

hi Bruno,

i have another site with same plugin and it works. i have changed default language to italian in this one, and now traslation from italian to english is not working right.
please check this page: hidden link
italian (default) is ok, english not traslate strings and spanish is OK.
let me know

best regards

Maurizio

July 9, 2019 at 10:27 am #4169673

maurizioB-11

i created a new product to test: hidden link

but english is not traslated

regards

July 9, 2019 at 12:07 pm #4170445

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

When you mentioned this:

i have changed default language to italian in this one, and now traslation from italian to english is not working right.

Can you check now?
hidden link

I went to:
WPML -> Localizzazione del tema e dei plugin -> disabled "Si presuppone che la lingua originale di tutte le stringhe sia l'inglese".

And translation seems to be working now:
hidden link

or:
hidden link

Regards,
Bruno Kos

July 9, 2019 at 12:46 pm #4170865

maurizioB-11

thanks a lot!

5 stars

best regards

July 9, 2019 at 12:46 pm #4170871

maurizioB-11

My issue is resolved now. Thank you!