This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Riffaz 3 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
July 9, 2019 at 4:08 am #4167443

vishalit

I am trying to:

Link to a page where the issue can be seen:hidden link

I expected to see: traslation

Instead, I got:original

July 9, 2019 at 4:11 am #4167445

vishalit

wpml is still not working on homepage

July 9, 2019 at 5:05 am #4167493

vishalit

MY PROBLEM IS NOT RESOLVED
STILL WPML IS NOT WORKING ON HOMEPAGE

July 9, 2019 at 6:49 am #4167807

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I see your homepage like this: hidden link

Do you mean that when you click on the flag in the language, it does not work, right?

If possible please go to WPML ->Languages and add a footer language switcher.
Are you able to switch languages in the front page using the footer switcher ?

And, what is your hosting?

Let me know.

Regards,
Riffaz.

July 9, 2019 at 7:32 am #4168129

vishalit

hello Raffiz,
i did footer language switcher still it not working.
my website hosting godaday

July 9, 2019 at 1:07 pm #4170969

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

GoDaddy has an issue with homepage settings in database.

Please contact your host provider (GoDaddy) they will work with you on fixing the issue

you need to make sure in wp_options "home" field is not empty and this will fix the issue

In wp_options there is the site_url field and the home field both should contain your sites URL.

With GoDaddy user is unable to change the homeURL please contact them and ask them to set your homeURL in the wp_options in the database .

Let me know how it goes.

Regards,
Riffaz.

July 10, 2019 at 2:05 am #4175107

vishalit

hello Riffaz ,
Thank you for help.I did set homepage on wp-options and its working now
but when i switch to other language , whole home page layout is changing . why??

July 10, 2019 at 7:07 am #4176475

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Glad, it works now.

if I switch to other language , whole home page layout is changing
- this is really a different issue.
- please close this ticket and create a new one for this to avoid the confusion and to reduce the waiting time.

Regards,
Riffaz.