This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The front end editor from Kallyas theme does not work for secondary language when using a different domain per language.

Solution: Set this option: WPML > Languages > Language URL format > A different domain per language > Auto sign-in and sign-out users from all domains

0% of people find this useful.

This topic contains 10 replies, has 3 voices.

Last updated by marcoI-5 1 year, 10 months ago.

Assigned support staff: Otto.

Author Posts
November 28, 2017 at 2:17 pm #1443684

marcoI-5

Hello,
I created my new site by changing themes by going to kallyas. I did all the work in the wpengine staging area. Now when I posted the site I noticed that if I want to edit the pages in English and French does not work the kallias editing editor. why?

November 28, 2017 at 4:59 pm #1443904

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

For being of better help, can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Please, make sure you are following these steps to translate the pages using the Kallyas theme:
https://wpml.org/documentation/theme-compatibility/kallyas-theme/

If this does not help, if this is not what you are asking, can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of “upload an image” below the comment area.

Let me know your results, please.

Kind Regards,

Otto

November 29, 2017 at 7:51 am #1444338

marcoI-5

Hello Otto,

We have created our new site in the wpengine staging area using the Kallyas theme.
Now we've released the new site by going live from staging.
Now if you see in the wpml area we have 3 sites for each language (see screen1) and we can not change it!
Now if I take a page for example created for English and want to edit it I do not see the kallyas editor page builder (see screen2 and screen3).
As you can see from screen3, the page opens but the page builder editor does not appear.
How should we do?

November 29, 2017 at 12:07 pm #1444666

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for the explanation.

If I understood properly this is only happening in the original pages as the translations are made using the Translation Editor, right? (https://wpml.org/documentation/theme-compatibility/kallyas-theme/)

Can you please do a few tests?

❌ Before proceeding please make a full website backup! ❌

1.
If you deactivate WPML does the issue persists?

2.
If you change the language URL format to language added as a parameter or directories? => WPML > Languages > Language URL format

3.
Finally:
-Back up your site first
-Deactivate all the plugins that are not related to WPML.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

Let me know your results, please.

Kind Regards,

Otto

November 29, 2017 at 1:24 pm #1444782

marcoI-5

Hello Otto,

the problem is not on the main pages (Italian) because here the editor works.
The problem lies in the secondary (English and French) languages where the page builder editor does not work (it does not appear at the click itself, as seen on the previous screen).

Also following your instructions:
- Steps 1 and 3, however, continue to run the editor
- Section 2 runs the editor in different languages is not good, because we need to have the "different domain for each language" setting.

so how do we fix it?

regards,

Domenico

November 29, 2017 at 2:19 pm #1444865

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Domenico,

Thanks for the testing.

I understand that changing the URL format is not a solution, I mean it as a test to isolate the issue. Please apologize for the misunderstanding.

Can you please test it? Does it work fine with other language URL formats?

Also, check if you enabled this option in WPML > Languages > Language URL format > A different domain per language > "A different domain per language"

Let me know your results, please.

Kind Regards,

Otto

November 29, 2017 at 3:28 pm #1444964

marcoI-5

Hello Otto,

yes, if modified as you suggested to the point the editor works for all languages.
Now as you see from the screen is set to "a different domain for language".

so in my opinion I have to find the right setting to make it work in this last mode, that is: "a different domain for language".

regards,

Domenico

November 29, 2017 at 4:12 pm #1445014

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Domenico,

Try checking "Autenticazione e disconnessione automatica da tutti i domini", please.

Let me know if this helps.

Kind Regards,

Otto

November 30, 2017 at 7:33 am #1445440

marcoI-5

Hello Otto,

I made the change you told me and now it works ... thank you

June 14, 2018 at 8:31 pm #2414284

hugoW-5

My theme settings dont work with wpml see hidden link

July 23, 2019 at 7:54 am #4263421

marcoI-5

Hello Otto,

I have updated the Wpml plugins but now when I try to change the content of the pages in the language using the builder editor, it doesn't work.
I get the http 500 error.
Why?

Even before the update I always had problems with wpml