If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 7 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 20, 2019 at 5:59 pm

carlo-albertoT

I am trying to:
Install WPML latest version (as of today, March 20th 2019) on Newspaper 9.6.1 and WP 5.1.1

Link to a page where the issue can be seen:
Not yet, since it doesn't seem to install

I expected to see:
WPML working
Instead, I got:
See uploaded pic. We have - at least -: 1) a problem with the table you can see as well; 2) the text in Italian says, roughly, 'WPML doesn't find some language table records and cannot correctly work until this problem is solved. To solve this problem, go to the Troubleshooting page and click on "Delete language information and enter it again". This warning will disappear as soon as the problem is solved' The problem is that even by clicking it, nothing changes; 3) "Please finish the installation of WPML first", but we don't see how to finish it. Moreover, in the WPML-Settings area, we can only choose languages; by clicking OK it doesn't proceed.
It barely seems that WPML isn't installed as it should. We placed relevant *.po and *.mo files in the translation folder as stated.
Installed plugins: WPML CMS Nav 1.5.0; WPML Media 2.5.0; WPML Multilingual CMS 4.2.1; WPML String Translation 2.10.1; WPML Translation Management 2.8.1

March 21, 2019 at 12:41 am #3394141

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. If it is a first time install and usage of WPML plugin you can proceed like these in order to reset the WPML related database tables:

1 - In your WordPress Dashboard > Plugins deactivate and activate the WPML Multilingual plugin.

2 - In your WordPress Dashboard > WPML > Support click the blue 'troubleshooting' link.

3 - Now under the 'Reset' section check the 'I am about to reset all translation and language data.' box and click the blue button to perform a reset action.

4 - Activate the WPML plugin again and try to finish the setup process.

See: https://wpml.org/documentation/getting-started-guide/

Again, only proceed if you still doesn't have any existing translation for your website. Please, let me know if it helps, have a nice day.

March 29, 2019 at 10:10 am #3490085

carlo-albertoT

Hi Marcos,
thx for the support. Actually we can handle this issue few times a week, so please be patient for our response times.
We proceeded according to your instructions and, unfortunately, it seems that nothing changed: we still have the same problem.

March 29, 2019 at 10:59 am #3490475

carlo-albertoT

An addendum.
We just deinstalled (i.e. deactivation & file deletion) both Newspaper Theme and WPML.
Then we installed a fresh copy (just downloaded the most recent) of Newspaper, and activate it.
After that, we downloaded fresh copies of the 4 WPML plugins (WPML Multilingual CMS, String Translation, Translation Management, Media Translation). Up to this moment, the website was running perfectly.

As soon as we activated the 4 WPML plugins, the same problem came up (see the included image, but the content is the same we already showed at the beginning of this ticket). Also, again, WPML cannot be configured.

March 29, 2019 at 1:12 pm #3491663

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. If you still don't have translations in your database, you can try the following:

1 - In your WordPress Dashboard > WPML > Support, click the blue 'troubleshooting' link.

2 - Now check the box 'I am about to reset all translation and language data.' and click the 'Reset and deactivate WPML' button under the 'Reset' section.

3 - Activate the WPML Multilingual CMS plugin and try to setup it again.

See: https://wpml.org/documentation/getting-started-guide/

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if it fixes your issue. Have a nice day.

April 5, 2019 at 8:40 am #3542189

carlo-albertoT

Hi Marcos,
thx for the new suggestion.
I followed what you said but nothing changed. At the end I activated WPML Multilingual CMS plugin as stated. See the included image (which is very similar to others I sent before). At the end I had 2 choices in WPML menu: Languages and Support. After clicking "Languages" I had no possibility to go over the first screen (the one with all the available languages).
I also tried to Clean Up but again nothing happened.

BTW: please note that for this site we usually work one day per week, so please be patienti for our answers. Thanks

April 5, 2019 at 5:37 pm
April 5, 2019 at 5:38 pm #3546197

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks!

April 10, 2019 at 3:21 pm #3577893

carlo-albertoT

Hello Marcos,
we carried out all the steps you mentioned. We found WPML was already installed, so we simply installed Newspaper.
In our site, instead, WPML had been installed *after* Newspaper.

The result is that there seems to be no serious problem.
The only exception was a reset of the page (please see the included image - mainly in Italian but I guess you can get it anyway) immediately after choosing the main language (1st step in WPML setup). Then we issued again wp-admin page, and everything proceeded as expected.

I don't know if our problem was due to some other component, such as conflicting plugin(s), or the different installation sequence between NP and WPML.

Please let us know how to proceed. Thanks a lot

April 10, 2019 at 4:54 pm #3578985

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Can you please, deactivate the Newspaper theme and try the WPML installation in your website using a default WordPress theme? Here are the detailed steps:

1 - Change to a default WordPress theme such as the 'TwentySeventeen' from your WordPress Dashboard > Appearance > Themes.

2 - Disable all the plugins from your WordPress Dashboard > Plugins settings.

3 - Activate all the WPML related plugins and try the setup again.

Please, let me know if it works on your end. Have a nice day.