We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 8 voices.

Last updated by Pierre 3 years, 10 months ago.

Assigned support staff: Pierre.

Author Posts
June 24, 2015 at 9:39 am #645069

Régis

Hi,
I've juste installed and configured WPML on a website (with latest versions of the WPML plugins) like I've already done for many websites.
Everything is OK except when I try to switch between languages on the website (eg. on the homepage), the website doesn't show the translated page but refresh the homepage.
The links in the footer language switcher seems to be OK yet.

I can send you URL and all credentials you'll need, just ask me how.

June 24, 2015 at 3:29 pm #645459

Régis

Hi,
I've tried to install WPML on another website and I've exactly the same problem!
Here, all plugins are also up to date with WordPress 4.2.2.

The behavior is the same.
I can create translations in wp-admin but it doesn't work on the website when I try to switch from one language to another.

Note: plugin is configured to skip language when there is no translation. Besides, I had to hide new languages except for admins, including myself (I've checked the checkbox on my profile)

hope hearing from you soon since that's a bit annoying 🙁

Regards

June 24, 2015 at 9:51 pm #645683

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Please as a test, could you disable all non-WPML plugins and see if the problem persists?

Also, the problem occurs if languages are visible?

Thank you.

June 25, 2015 at 7:41 am #645882

Régis

Hi Bruno,
Websites are both on production environment so I can't do that.
But I have both of them, running on staging environments, with the same WP and plugins versions.
I can't reproduce the error on these staging environments.

I've quickly done the test with visible language, and you're right, the problem seems to be related to this feature...

That's annoying since I can't let users access to these languages till the website isn't fully translated.
Is there a real bug ?
Is it a server configuration issue ?
Is there a workaround I can use to prevent regular users and crawlers from seeing these new languages?

Regards

June 25, 2015 at 12:44 pm #646240

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Yes. This seems like a bug. I will report this issue to our developers.

As a workaround, you can uncheck the options to display the language selector in the menu and footer. Thus users will not have access to translations.

Sorry for the inconvenience.

Thank you.

June 26, 2015 at 10:30 am #647022

Régis

Bruno,
what about crawlers?
Can I do something to prevent Google from reading my translated pages before website is completely translated?

June 26, 2015 at 2:25 pm #647315

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

I am Pierre from 2nd tier support.

This issue has already been reported and escalated to the development team. However, I can't provide any time frame for this issue to be fixed. I will update this thread as soon as I have a feedback.

Note that the language switcher will not display the hidden languages links if you are not logged in. So search engine crawlers won't see links to hidden languages.

Regards,
Pierre

July 8, 2015 at 6:14 am #654619

randalN

I have the same problem with 2 sites who are in the finale stage of production. When switching the language the user goes back to the home page of the main language.

August 17, 2015 at 7:46 pm #681012

Shahar

Any update on this please?

October 9, 2015 at 10:43 am #721396

anaV-3

Hi!
We're having the same problem: if we hide some languages and check the Display hidden languages option in our profiles, we can't see the translated pages at all. They are always redirecting to the home page.

hidden link

I guess the alternative while this isn't solved is to show all languages for all users and simply hide the language selectors on the menu via CSS. But this isn't clean, so

any real solution or estimated time to fix this bug?

Thank you

October 14, 2015 at 8:48 am #724474

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello,

We've been trying hard to replicate the issue without success, until today.
We are now able to address this problem and will provide a fix in the next release.

Sorry for taking so long to come back to you.

Regards.

October 29, 2015 at 1:23 pm #735516

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

This is just to inform you that this issue will be solved in next WPML 3.3 version. We released a WPML 3.3-RC1 version for test purpose. If needed, you can download it in Account >Downloads. Please do not use this RC version on a production site.

Regards,
Pierre

December 25, 2015 at 2:39 pm #776510

melR

I'm having the same problem. The pages won't translate and everything is just in English.
hidden link

Also, the sunrise.php does not maintain the subdomain when I input the URL into the browser

December 28, 2015 at 11:03 am #777055

Pierre
Supporter

Languages: English (English ) French (Français ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @melr,

The problem you are experiencing might be a different one as your setup is also different. Can I kindly ask you to open a new ticket? Please provide your debug information http://wpml.org/faq/provide-debug-information-faster-support/.

Regards,
Pierre