This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 3 voices.

Last updated by Stéphane 2 years, 9 months ago.

Assigned support staff: Sumit.

Author Posts
December 15, 2016 at 8:03 pm #1161614

Stéphane

Hi !

I'm using Total Theme which is compatible with WPML.
I have translated some strings from the customizer, which is in Domain: Theme Mod
Some do translate, and some don't.
(FYI, all translated strings are marked as "Translation complete")

URL of (my) website where problem appears:
hidden link

For exemple, on the top bar of that page:
hidden link
You can see "Get A Feasibility" and if you switch to french, you get the string translated as "Obtenir une faisabilité". That's just to let you know that I know how to make it work 😉

On the other hand, there are a few strings that won't translate. Here is a few exemples:

On the page:
hidden link
"DBM REFLEX NEWS" does not translate.

Another exemple:
When you load a page in english, in the center of the browser, you can see "Loading..." appearing. When in french, it should be "Chargement de la page ..." but it doesn't work.

Also, on the page:
hidden link
The address on the right "1620, boul. Dagenais West" should be translated as "1620, boul. Dagenais Ouest" but it doesn't.
This string comes from a widget build by the Total theme, which file is: info.php

That string doesn't even appear in the string translation panel, even after scanning the theme many times. The file is scanned (as you can see in the screenshot) but the string doesn't show up !

Thanks in advance to help me correct that situation.

December 16, 2016 at 2:30 pm #1162328

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Thanks so much for the details and the screenshots, that's very helpful for me to know exactly what is going on 🙂

For the strings that are not showing up in in String Translation after you scanned the theme, it could be that these texts are stored in the wp_options table. This would mean they are in the admin texts and need to be added to String Translation. To do this, please go to WPML > String Translation and scroll down to the bottom of the page and click on the link "Translate texts in admin screens »". Then, scroll through that page and see if you find the the string (You likely will need to expand a section titled thememods_total). If so, tick the checkbox and click Apply to add it to the String Translation table. Now you can go back to WPML > String Translation and you should see the string added there.

For the strings that you have already translated, please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

Let me know if this resolves any of the untranslated strings. Thanks!

December 16, 2016 at 9:32 pm #1162659

Stéphane

Hi Lauren,

Thanks a lot for those information.
I must say that this "Translate texts in admin screens" is nearly hidden ! 😉

I followed your instructions, and it nearly works ... I explain:

I could add the strings and translated them, but what is strange is that when I go to a french page, sometime the translation loads, but sometime not. When it doesn't load, after refreshing the page, it finally comes which the translation ... but not always. Sometime I have to reload the page a few times before it translates.

Also, the only string I could never get to work is the string from the info widget, in the Headquarter page.
hidden link

In the address, West never get to Ouest in french.

I asked through the form on the site to have a video call for a live support, on monday morning. I don't know if it's supposed to be with you, but as you are the one helping me now, would you be available for that ? If not, it could also be another time.
For your information, I'm in Montreal, so that's eastern time. Let me know ...

And thanks again for helping.

Stéphane.

December 19, 2016 at 3:39 pm #1163879

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Stéphane, I'm happy to hear that most of the text admin strings are translating correctly.

For the content that is only sometimes showing, I wonder if that could be a caching issue. Do you have a caching plugin installed, or server caching set up? If so please try disabling that and see if there is any difference. If not, please try temporarily disabling other plugins and see if that makes any difference.

As for the info widget, can you tell me specifically which string you translated that is not appearing translated on the frontend of your site? Thanks!

December 19, 2016 at 9:08 pm #1164179

Stéphane

Hi Lauren,

It's not a caching issue, because I have no active cache plugin activated, ans on the server, it is deactivated too. So, the problem is still there, on and off after reloading the page.

On the other side, concerning the info widget, the string that doesn't translate is:
"1620, boul. Dagenais West" which in french should have "West" written "Ouest".

Thanks for helping.

December 20, 2016 at 2:01 pm #1164840

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

December 22, 2016 at 5:59 pm #1166947

Stéphane

If you want to reproduce the bug, here is an exemple:

Go to:
hidden link
Click "Français" on the main menu
Then click on "Nouvelles"
There, you'll see that in the header, "Get a feasibility" and the copyright in the footer are not translated.
Reload the page and ... tadam, everything get the translation !

December 22, 2016 at 7:53 pm #1167023

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you, I can see what you are referring to in that header line "Get a feasibility". I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. Does this resolve the issue?

If you don't have a testing environment available and cannot test this on your live site, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to set up your site locally and run these tests for you.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply. I will also need the username and password of a user that was created before the duplicator package was created.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it. Thanks!

December 26, 2016 at 7:49 pm #1168553

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for sending credentials. I am discussing this issue with our compatibility team to further troubleshoot. In the meantime, I did notice that Visual Composer and Ultimate Addons for Visual Compser plugins are not the latest versions. Can you please try updating those to the most recent versions and let me know if this changes anything? Thanks!

December 27, 2016 at 3:07 pm #1169156

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Also, can you please confirm with your hosting provider that caching is disabled? Because if I view your site for the first time in a private browser or incognito browser, it shows the correct French translation the on the first visit without having to refresh the page.

January 3, 2017 at 8:51 pm #1173808

Stéphane

Hi Lauren,

Sorry for the delay and ... happy new year ! 😉

Concerning your request to update the 2 plugins, I have one comment:

I can't update Visual Composer by now because it comes with the Total theme, and they did not updated it yet.
Concerning Ultimate Add-ons for VC, I did update it.

As a conclusion, the problem are still there, even with that update.

January 3, 2017 at 9:05 pm #1173814

Stéphane

Also, concerning your request for me to check if there would be any cache enabled on the server, I confirm that all cache is disabled.

On my side, looking at the website in a private window for the first time, changes nothing to the problem. It reacts exactly the same way, meaning that generally, I have to reload the page 1 or 2 times to get the translations in the Top header and the Footer.

Thanks to keep on looking for a solution.

January 5, 2017 at 1:29 am #1174875

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for the update. That is odd that for you, in a private browser, that it is not working correctly. I will continue to troubleshoot and I will also run a test with the latest version of Visual Composer and report back here my findings. Thanks again for your patience.

January 5, 2017 at 6:28 pm #1175623

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have escalated this to our Compatibility Support team. I will be working with the developers and will keep you updated here. Please keep in mind that a resolution may depend on how quickly the theme author responds to us. Thanks for your patience while we continue to troubleshoot.

January 9, 2017 at 12:23 pm #1177463

Sumit
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi Stéphane,

I am Sumit from 2nd tier support.

As I can see you've registered "Get A Feasibility" two times thus creating an issue. I have deleted one with domain "admin_texts_theme_mods_wordpressman-child" (It is added by translate admin string in String Translation).
Please ignore this and translate only with the domain "Theme Mod".
It is working fine for me now. Can you please check?

Thanks