This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.78 hours from now. Thank you for your understanding.

This topic contains 12 replies, has 2 voices.

Last updated by josep-oriolT 2 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 8, 2019 at 1:02 pm

josep-oriolT

Hello,

After some months without adding new GeoDirectory listings, today I started again.

To my surprise, the WPML functionality of duplicating the listing in the main site language to the translated languages does not work correctly.

This is the first new listing I started to add:

hidden link

After publishing it, I checked the duplication boxes of the translated languages and, after a while, they appeared as duplicated, as usual.

However, the fields contents have not been copied to the translated language listings. Also, accessing them from the WP backend, one of them shows the options to be overwritten or copied from the main language listing (as if it was already independent) while the others show the option to be translated independently.

I look forward to your reply.

Thank you very much for your help.

Best regards.

August 8, 2019 at 5:36 pm #4365117

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Before a more detailed investigation can you please confirm if you have installed the GeoDirectory Multilingual addon and followed their official instructions on how to setup it at: hidden link? I couldn't confirm it as the 'plugins' admin section of your WordPress Dashboard is hidden for me. Please, let me know so we can proceed with our support efforts. Have a nice day.

August 8, 2019 at 5:52 pm #4365233

josep-oriolT

Hi Marcos,

Thank you very much for your response.

Yes, I confirm that I have installed the GeoDirectory Multilingual addon and followed their official instructions on how to setup it at: hidden link

The "plugins" admin section of my WordPress dashboard can be found under the label "Extensions". I have not hidden it for any user role enabled to login

I look forward to your news.

Thank you very much for your help.

Best regards.

August 9, 2019 at 9:24 am #4368965

josep-oriolT

Hi Marcos,

Now I see that that plugins menu was disabled from the WP Multisite network parameters. I have enabled it.

Please, excuse me for my assumption. I never noticed this parameter before.

I look forward to your news.

Thank you very much once again for your attention.

Best regards.

August 9, 2019 at 6:20 pm
August 9, 2019 at 6:21 pm #4372397

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks.

August 9, 2019 at 7:20 pm #4372591

josep-oriolT

Hello Marcos,

Thank you very much for your reply.

Unfortunately, I get an error message when trying the migration (screenshot attached).

Please, note that my site is the main site of a WP multisite network and the Cloudways Migrate form does not ask for Database User and Password.

I look forward to your news.

Thank you very much once again for your help.

Best regards.

August 9, 2019 at 7:24 pm #4372667

josep-oriolT

Hello again,

I am trying now for the third time, now after clearing cache (I forgot to do it before), and it seems to work.

Best regards.

August 9, 2019 at 8:17 pm #4372885

josep-oriolT

Hi Marcos,

Unfortunately, after the migration process finished, error "migration failed" appears (screenshots attached).

I look forward to your news.

Thank you very much once again for your help.

Best regards.

August 9, 2019 at 8:27 pm #4372951

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. In this case, let's try an alternative approach: To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Note: I am in the end of my work shift for today, I will be back with a reply on the next monday if it is okay for you.

Thank you for your collaboration. Have a nice day.

August 10, 2019 at 7:37 am #4374831

josep-oriolT

Hi Marcos,

Thank you very much for your response.

I think that I have found the issue that caused the Cloudways Migrator to fail. I have tried again but I suspect that you already deleted the Cloudways app.

If you create it again and you let me know its credentials, I will try again the Cloudways Migrator.

I look forward to your reply on Monday.

Thank you very much once again for your attention.

Best regards and have a nice weekend.

August 11, 2019 at 2:59 pm #4377077

josep-oriolT

Hi again,

I am very sorry, this was not an issue, but a bad procedure. I have done it hundreds of times before and now for days I have been doing it in the wrong way once and again.

Just to remember forever:

1) Publish.
2) Duplicate.
3) Update! (I was omitting this step! 🙁 )

Please, accept my most sincere apologies.

Thank you very much for your patience and help.

Best regards.

August 12, 2019 at 2:58 pm #4381759

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. is the issue solved? Please, let me know so we can mark it as solved and close it. If you need any additional assistance and help, please don't hesitate in getting in touch with us. Have a nice day.

August 13, 2019 at 6:22 am #4385225

josep-oriolT

My issue is resolved now. Thank you!