Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Elementor Buttons not translating the before/after text

Solution: Please update WPML and all its add-ons to their latest versions.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.11 hours from now. Thank you for your understanding.

This topic contains 26 replies, has 4 voices.

Last updated by Alejandro 2 months ago.

Assigned support staff: Alejandro.

Author Posts
January 17, 2019 at 5:46 pm #3103336

shaneB-8

4) It's my fault if you didn't find this option, it's not there anymore. you can now find it in WPML > Settings > Post type Translation > Find and set to "translate" the following:
- Groupes de champs (acf-field-group)

This was already set properly.

then in WPML > Settings > Custom post field translation > Find and set to "translate" the following:
- call_to_purchase

Already set to "Translate"

You can now proceed with the next steps:

5) Update the page (add some text or change the name of one of the fields)

I updated the Elementor template as suggested, and also (for the sake of testing) add some text to the after section. HEY! Perhaps the reason that your code is not workign is that it is not targetting these types of fields in page templates! In fact, this is a product template to create a base design.

January 17, 2019 at 6:35 pm #3103464

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'll take another look, because that shouldn't really matter in this case, but i'll try checking the installation i have with the code change and check what happens with a product template.

In the meantime, would you mind giving me credentials to your site again? i'm afraid i can't find them anywhere else.

Thanks in advance.

January 17, 2019 at 7:18 pm #3103607

shaneB-8

Actually you can just use the existing site that I just uploaded to test things out if you like. It's the same!

January 21, 2019 at 4:01 pm #3113135

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

You're right it doesn't work correctly on products. i just informed our devs and they are looking into this.

January 28, 2019 at 10:24 am #3134902

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,
I just wanted to inform you that we escalated this from our compatibility team to our core development team because it requires a different solution from what we were suggesting to you.

I'll keep you updated.

January 29, 2019 at 1:33 pm #3139876

shaneB-8

Happy to hear that I found a bug and that you will fix it thank you!

March 1, 2019 at 9:52 am #3259400

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi! i think i might have a workaround for your issue given that the problem is probably take some time to fix (they are still working on it).

Please update WPL to 4.2.X and now you will have the option to disable the editor in only certain pages. disable it in the page where the dynamic custom ACF field is and fix the page over there.

that should keep you from waiting any further and as soon as we get the solution working we'll let you know.

Have a lovely day!

March 1, 2019 at 12:00 pm #3260189
Stefano

Hi, I'm having the same issue. I'd like to know if you will still give updates here about Developers Team news.

January 29, 2020 at 8:22 pm #5387319
Pavel

Hello WPML team, are you still working on this issue? Still no such option to translate BEFORE and AFTER strings.

New threads created by Alejandro and linked to this one are listed below:

https://wpml.org/forums/topic/split-wpml-elementor-buttons-not-translating-the-before-after-text-3/

January 30, 2020 at 8:38 pm #5395163

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi guys, still no updates, unfortunately. our devs have tried many things but all those tests have failed.

I am splitting bot of your tickets so i can try to increase the priority on this issue.

Regards.

August 25, 2020 at 2:06 pm #6869443

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

Could you update to our latest release (or even try the beta version) and see if the problem is fixed now?

Thanks in advance.

July 17, 2021 at 11:06 am #9221837

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I didn't hear from you for a long time so i'll close this ticket.

Please open a new one if the problem is still there.

Regards.