We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I can't set Elementor conditions or exclusions.

Solution: Please update your plugin to WPML 4.1.4 and relative Add-ons versions.

Relevant Documentation:https://wpml.org/2019/01/wpml-works-fine-with-wordpress-5/

This topic contains 36 replies, has 3 voices.

Last updated by Alejandro 10 months ago.

Assigned support staff: Alejandro.

Author Posts
November 17, 2018 at 10:11 pm #2916455

shaneB-8

WPML 4.0.8
Elementor 2.3.1
Elementor Pro 2.1.13

I am trying to:

1) Created a template for all pages
2) Set the exclusion for specific pages (Cart, Checkout, and one called Hebergements)
3) Exclusion works for Cart, Checkout, but does not work on translated Hebergements page which is using Elementor

Link to a page where the issue can be seen:

hidden link

You'll notice there is an extra slider at the top which should be excluded in the English version here hidden link

I expected to see:

No slider at the top on the English version as it is setup in the French. I think there is a glitche in exclusions that seems to not link these two together or something...

November 19, 2018 at 10:11 pm #2921098

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

This issue was resolved with the release of Elementor 2.2.0, which was just released. You can reference this similar ticket: https://wpml.org/forums/topic/elementor-templates-display-conditions-not-working/page/2/#post-2741017

Please update to the latest release and let me know if this resolves the issue.

November 20, 2018 at 2:29 am #2921546

shaneB-8

No unfortunately it doesn't. I also updated today and had noticed this issue queue post already. I have now :

* Resaved and retranslated the template (no deleting the second language)
* Resaved the page in question and retranslated (not deleting the second language)

And nothing has changed.... so what can we do to resolve this?

November 20, 2018 at 2:30 am #2921556

shaneB-8

Also it would appear that I am having a similar issue whereby my footers aren't being translated now as well.. but perhaps I need to report that as a separate issue?

November 20, 2018 at 1:38 pm #2923346

shaneB-8

Great! I have completed the migration. To repair my footer issue I attempted to remove the translated Footer (English) version, and now //no// footer appears whatsoever in English. If I go to edit that template in English to see that it ported over there is //no content// in it. The other older templates have the ported content. I don't know if the patch in Elementor fully broke stuff but something seems not correct.

In either case, the templates should just migrate to English so if you could help me resolve this I would be most appreciative!

November 20, 2018 at 4:44 pm #2924070

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

The best way to translate a template is to duplicate it into the second language, then click "Translate Independently".

Which template are you testing that is showing up on the wrong conditions? I edited the English templates using Elementor and I don't see any conditions added for any of the English templates. Have you tried adding the conditions?

November 20, 2018 at 5:24 pm #2924189

shaneB-8

There are conditions there I'm not sure how you could see that there aren't. Which templates did you edit and did you check the page in question that we were talking about at teh top of the post?

November 20, 2018 at 5:27 pm #2924204

shaneB-8

Oh I see where you are going wrong. The default language is French, and the other language is English. The primary templates are all in French where you will be able to see the proper conditions. Then from there you can see that the languages are all translated.

November 21, 2018 at 2:56 pm #2927165

shaneB-8

Any luck?

November 21, 2018 at 4:39 pm #2927568

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, my name is Alejandro,

Since Lauren is currently not available, I will replace her here in the forum.

I hope this is OK with you.

I'm still testing this issue, I'll let you know my findings soon.

November 21, 2018 at 11:08 pm #2928356

shaneB-8

Any luck? Do you see where the problem lies... I suspect this is a second tier problem since I cannot see any misconfiguration on my part. It should just translate but doesn't. It's like the conditions are not being run through the translation scheme

November 23, 2018 at 8:14 am #2932938

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

First of all, sorry for the late reply, i've been testing and debugging the issue. I was able to replicate you problem and as a last test i need you to try and replicate this issue on a sandbox environment:

hidden link

Click the above link and if you can try to migrate both that page and elementor condition, in order to see if even in there the problem is persistent. if it is, then return here with the steps taken in order to replicate the issue and we'll take it from there.

Let me know how it goes.

November 23, 2018 at 9:12 pm #2935403

shaneB-8

Hey

I don't think I really understand your request. There is no settings nor is there Elementor in there. Could you not use the version I duplicated for you instead. I cannot see any settings that I should port over since the link contains no conditionals or Elementor. Am I missing something?

November 26, 2018 at 1:54 pm #2940405

shaneB-8

Also, I wanted to add that for me to go through and add all the content including products, and settings would take some time. Does your solution resolve both the conditions and the issue I am having with footers?

November 26, 2018 at 5:20 pm #2941463

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

I just wanted to let you know that i'm working on the environment you provided and i'm trying to isolate the issue just to find its cause.

I can also confirm that there's no need for you to do anything else, so as soon as i have an answer i'll post it here.

Thanks for your patience and understanding.