Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I can't set Elementor conditions or exclusions.

Solution: Please update your plugin to WPML 4.1.4 and relative Add-ons versions.

Relevant Documentation:https://wpml.org/2019/01/wpml-works-fine-with-wordpress-5/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 36 replies, has 3 voices.

Last updated by Alejandro 2 years, 9 months ago.

Assigned support staff: Alejandro.

Author Posts
December 23, 2018 at 4:53 pm #3028960

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, the problem you were facing with elementor should now be fixed in WPML V4.1.3,
Please update our plugins and let me know how it goes.

Regards,
Alejandro.

December 30, 2018 at 2:19 am #3042748

shaneB-8

I'll give this a try when I get back to the office on the week of January 8th. Thanks for working on this and letting me know it should be resolved.

December 31, 2018 at 7:42 am #3044287

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

No problem, check it out and let me know when you can.

January 14, 2019 at 3:12 pm #3088360

shaneB-8

I will test this out tomorrow and give you a report back on whether it is working properly. I was awaiting some financial approval so it got a bit delayed! Happy New Year

January 14, 2019 at 4:13 pm #3088669

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Sure,

Let me know when you do.

Regards.

January 15, 2019 at 6:15 pm #3094349

shaneB-8

Alejandro! It's working. I might add that some note should be made that there is NO need to modify the translated contents conditions as it respects the originals. The include and then exclude functionality is perfectly working.

Could I please suggest that you have some testing scripts (if not already) to verify that this problem doesn't creep up again. I feel that Elementor is still young and attempting to make their theme even more awesome. As such, I could see WPML breaking again under normal and more advanced conditions such as this.

Thank you sooo much for your time!

January 16, 2019 at 7:22 am #3096318

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I'm really glad it works!