This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by desmondc-2 2 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
August 9, 2019 at 11:04 am #4369595

desmondc-2

I've try to install the WPML, but it makes a lot of error after I install

Here are my error:

supplied for foreach() in /home/kpelderc/domains/kpeldercare.com.hk/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 677

Warning: Invalid argument supplied for foreach() in /home/kpelderc/domains/kpeldercare.com.hk/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-otgs-installer-plugin-finder.php on line 26

Warning: Invalid argument supplied for foreach() in /home/kpelderc/domains/kpeldercare.com.hk/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/repository/class-otgs-installer-repositories.php on line 54

Warning: Invalid argument supplied for foreach() in /home/kpelderc/domains/kpeldercare.com.hk/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 2395

Warning: Invalid argument supplied for foreach() in /home/kpelderc/domains/kpeldercare.com.hk/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 2433

Warning: Invalid argument supplied for foreach() in /home/kpelderc/domains/kpeldercare.com.hk/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 2445

Warning: Invalid argument supplied for foreach() in /home/kpelderc/domains/kpeldercare.com.hk/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 1074

Warning: Invalid argument supplied for foreach() in /home/kpelderc/domains/kpeldercare.com.hk/public_html/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php on line 1808

August 9, 2019 at 6:42 pm #4372477

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

are you currently using any drop-in cache plugins ?

ex. object-cache.php , it would be found within wp-content/plugins/ directory

If possible i would like to take a closer look at the backend to further test this issue

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

August 12, 2019 at 6:36 pm #4383099

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i have test the site using your duplicator package on my local environment and i was not able to reproduce the warnings

if possible please remove the current WPML plugin, and re install it with a new version from here https://wpml.org/downloads/ ( i currently do not have access to remove/install plugins)

afterwards clear your site's cache and let me know your results

August 12, 2019 at 7:39 pm #4383445

desmondc-2

Hi Bobby,I still get the error and I don't know why...

August 12, 2019 at 7:59 pm #4383511

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

if possible please provide me with super admin access so i can activate/deactivate the WPML plugin as well as also verify the FTP access details so i can take a closer look as i am not able to reproduce the issue on my local environment

Also please verify your wp-config.php settings as i do see you are using a multisite , there could be a chance on of the multisite settings is not configured correctly

as another test try the following as well that has worked for other users that experienced a similar issue in the past

Please follow the steps below:

- Go to Dashboard -> Updates
- Press the "Check again" button
- Scroll to the bottom and press the "Update" button

August 12, 2019 at 8:25 pm #4383535

desmondc-2

I setup the test account to the super admin,and I try your step also,but still not working

August 13, 2019 at 1:39 am #4384115

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Unfortunately i am still not able to access your site's FTP , if possible please verify the access details .

Also go to wp-config.php and verify that everything is set up well for the multisite

also you can safely remove these warning by doing the following

Go in your wp-config.php file and look for define(‘WP_DEBUG’, true);. Change it to:
define('WP_DEBUG', false);

let me know your results

also verify that the following are whitelisted as i get the following connection error as well

<em><u>hidden link</u></em>
<em><u>hidden link</u></em>
<em><u>hidden link</u></em>
<em><u>hidden link</u></em>

2019-08-13 01:20:206723 index wp_error wpml-config/config-index.json
code: http_request_failed
message: cURL error 7: Failed to connect to cdn.wpml.org port 80: Connection timed out

August 13, 2019 at 6:31 am #4385237

desmondc-2

I changed to define('WP_DEBUG', false); but it seem still same, and I asked the web hosting to verify the 4 connection

August 13, 2019 at 6:34 am #4385249

desmondc-2

also,can I set the website without multisite,I don't know why it will setup to multisite

August 13, 2019 at 7:43 am #4385649

desmondc-2

I just edit the ftp link, please check the private message at before again

August 13, 2019 at 11:11 pm #4391067

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i was able to resolve the warnings following the steps bellow :

1. Unregister WPML 2. Go to Dashboard->Updates->Click on "Check again" a few times and warning is resolved

please confirm with me that the issue is resolved after you have re registered your site

to register WPML follow the steps here

go to https://wpml.org/account/sites/ there you should be able to see your site registered (unless u never register your site before)

then click on the little trash icon

and follow the steps shown in the video hidden link

August 13, 2019 at 11:45 pm #4391121

desmondc-2

My issue is resolved now. Thank you!