This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 2 months, 1 week ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 29, 2019 at 6:40 pm #4302921

Adam

Hi,

I have a French and English website using The Events Calendar. My site is set to default in French.

I have recurring events in The Events Calendar and they have always worked until recently.

If I create a recurring event in French it works for a few weeks and then for some reason some of the recurring events show up on the English calendar instead of the French calendar.

In this example my recurring event is set to be every Wednesday and Friday until the end of August. It worked up until August 2. Starting August 7th all my events are only showing on the English side and no longer on the French side.

If I go in the admin as English under Events I see my French events listed in the list of events. To me that means the events are for some reason in English.

The odd part is that when I go in the admin under French and under Events I don't see the French events listed.

Now the kicker is, if you click that event, it brings you to the event page and the language of the event is indeed in French.

Something is messing up the French vs English and I don't know what it is.

See screenshots attached.

Capture1 - This is the list of events when in English. The french events missing on the french calendar are in the list.

Capture2 - This is what happens when I click on the event from the English listing. It brings me to the French event.

Capture3 - This shows the French calendar with the French recurring events. Working well.

Capture 4 - This shows the English calendar with the French events starting to show up on the English calendar. This is not good.

It's like if the recurring events at some point lose their original language and get set to English.

Any ideas?

Thank you

July 30, 2019 at 1:35 am #4303963

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

August 1, 2019 at 2:08 pm #4322533

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Please, take a look at my private reply above. Thanks.

August 1, 2019 at 8:29 pm #4325055

Adam

Hi,

So I did the migration. It did 1.60 gb of 1.60 gb. It did the database and then it crashed about half way through the files.

I received this error :

Oh no! It seems a problem has occurred while migrating your site to Cloudways. We apologize for any inconvenience this may have caused.

Kindly contact us as soon as possible via live chat for a satisfactory resolution of the problem.

Sincerely,
The Cloudways Team

Let me know what I should do now..

Thank you

August 2, 2019 at 12:04 am #4325599

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Most likely the size of your files (1GB+) made the migration process to fail, so let's try an alternative method: To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

August 2, 2019 at 6:34 pm #4332145

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I will proceed with the migration of your website using your database dump. I would need some extra hours in order to debug your issue into details, I will update you here as soon as I have some more details and an accurate answer. Thank you for your patience and understanding, have a nice day.

August 7, 2019 at 2:40 am #4351411

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for your patience while waiting for a solution. Due the file size of your dump database file, unfortunately my migration process is still not succeeded. I will keeping trying using alternatives methods to import it. For now, please, proceed this way:

1 - Review any cache plugin or server side cache you may have and disable it, then test your website.

2 - Create a new test event in both languages and let me know if the issue happens again.

3 - Enable the WP_DEBUG mode and take a look at the log file for any suspect error message (see https://wpml.org/documentation/support/debugging-wpml/).

4 - Disable all the Events Calendar addons and keep only the core plugin enabled.

5 - Make sure all the related Events Calendar plugins are updated to their latest versions.

Please, let me know the results for the tests above. I will keep trying to migrate your website and make a detailed investigation at my side as well. Thank you for your continued patience and understanding, have a nice day.

August 7, 2019 at 2:11 pm #4355873

Adam

I have to admit I am pretty disappointed with this reply.

Do you want me to send over a different MySQL file?

The 1 to 5 steps you detailed above is basically the "standard reply" to every problem.

2. Yes it will work if I create a new test event. It will eventually break again. I've been through this already. Last time I removed all the wrong language events, proceeded to create new ones, and then two weeks later I still had issues.

4. I doubt this will help anything. This is clearly a language issue. The language of the post shows one thing in the Page list view and the other in the actual post edit page.

5. This is the first thing that I did.

August 8, 2019 at 2:37 pm #4363949

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Adam,

Thank you for the updates and sorry for not giving you the reply you expect. Actually in order to provide an accurate answer we always try a fully investigation and then, after reproducing the issue and finding a solution we guide the customer on how to achieve it in their production website.

I'm trying to import your database for hours not working up to now, I even reinstalled xampp, increased resources but no lucky. It would be really appreciated if we have any means of investigating it without interfering in your website, usually migrating a website using either duplicator or a database exported file and the wp-content folder have worked for me in the case of 99% of customers tickets, I regret the fact it is not working for you.

Do you have any stagging website setup we can take a look? Is it possible to use the WP All in One Migration plugin (https://wordpress.org/plugins/all-in-one-wp-migration/) in your wpengine setup? It really would help to proceed with my support efforts of helping you with this issue.

By the way I took another look in your website and this time I couldn't see the mixed events, everything seems to be listed separated by languages properly, did you manage to solve it by yourself, if so, which steps did you follow? It eventually will help others facing the same issue. Once again, please, accept my sincere appologies for being stuck in the migration process. Have a nice day.

August 8, 2019 at 2:44 pm #4364017

Adam

Hi,

It was taking too long so I recreated the events.

I have a way to give you access to a staging site where you can do whatever you want to it.

Can you give me a way to send you this information privately?

Thank you

August 8, 2019 at 2:55 pm #4364075

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Adam,

Thank you for the updates. The next reply is private so you can provide these access details safely. Thank you for your collaboration, have a nice day.

August 8, 2019 at 7:01 pm #4365523

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Adam,

Thank you for the provided details. In this case we need to perform the same actions that triggered the events issues in your production website, maybe a plugin update, an event added and things like this. Is there any specific event you think can be of help to replicate this issue? Please, let me know, have a nice day.

August 8, 2019 at 7:07 pm #4365533

Adam

Nothing I can think of so at this point we could put this on hold.

For the next time I will have the staging site set up and I can quickly share you access to it.

August 9, 2019 at 12:48 am #4366363

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Adam,

Thank you for the updates. In this case, feel free to open up a new ticket if the issue appears again, with a stagging website setup will have some more means of investigating it in the future. Have a nice day.