This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Marcos Vinicios Barreto 4 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
May 29, 2019 at 5:44 pm

adwin

I am trying to: have flag images load over https

Link to a page where the issue can be seen: hidden link

I expected to see: https

Instead, I got: Mixed Content: The page at 'hidden link' was loaded over HTTPS, but requested an insecure image 'hidden link'. This content should also be served over HTTPS.

May 30, 2019 at 1:49 am #3919291

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Was your site previously set at http and then changed to https? In that case elements (like the switchers) you may have created at that time may be still showing an old value.

If you have problems with mixed content warning after update from http to https with WPML language switcher, there is the possibility that the language switcher is still being cached.

You can try and clear the cache from WPML > Support > Troubleshooting -> Clear WPML Cache and also to disable the template language switcher cache.
Another workaround would be to remove all language switchers and re-add them manually.

Please check also if you have "WP_SITEURL" or "WP_HOME" defined in your wp-config.php. If so, check if they're using https instead of http. you can also try to remove them and see if the errors persist.

Please check also if you're using any caching plugin in your site or server. Try to deactivate them and check if the issue persists.

If you install and activate any plugin similar to "WP Force SSL" plugin (https://wordpress.org/plugins/wp-force-ssl/) it will help you to force all unsecure elements to be SSL.