This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Shekhar Bhandari 3 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
July 8, 2019 at 10:44 am #4161367

nadineL-4

Hi,

this is what the plugin developer send me:

The footer templates are stored in the Divi Library, they are a custom post type 'et_pb_layout'. The 'footer_1' is the id for that footer. We load the footer with that id from the Divi Library with a simple WP loop like this:

$args = array(
'post_type' => 'et_pb_layout',
'title' => $title,
'post_status' => 'publish',
);

$my_query = new WP_Query($args);
if ($my_query->have_posts()) {
while ($my_query->have_posts()) : $my_query->the_post();
echo '<footer id="ddp_footer">';
the_content();
echo '</footer>';
endwhile;
}

wp_reset_query();

does that help you?

July 8, 2019 at 10:50 am #4161399

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the details.

Could you please provide me login details so I can check the issue further?

To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

July 8, 2019 at 10:53 am #4161457

nadineL-4

Hi,

the login details are the same I send to you in the chat. Do you still have them?

Thanks.

July 8, 2019 at 10:58 am #4161473

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

If you go to Divi Library and check the id of the "Link Me Footer", it's "209568" so it's confusing, can you ask with them if this is the same id they are referring to?

Look forward to your reply.

Thanks

July 8, 2019 at 11:14 am #4161699

nadineL-4

Hi,

this is what they say:

It's not the same id. We are not using custom posts ids at all. I've sent you the code we are using to load the footer, please send the code to the WPML support.

We cannot debug the WPML plugin because we do not have a copy of the plugin. Please provide us with admin logins to your site if you want us to debug the WPML and DDPro.

Does that help?

July 8, 2019 at 11:47 am #4162061

nadineL-4

This is what they say now:

Okey, we think it's more global than just the DDPro plugin.

Can you please ask WPML support if the WPML plugin is able to translate the items in the Divi Library at all?
Here is the link to the Divi Library: hidden link

We cannot find any info about Divi Library Items in that article https://wpml.org/documentation/theme-compatibility/divi-builder/

do you think it is possible to solve it?

July 8, 2019 at 11:52 am #4162125

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, it's possible to translate the Library items as mentioned here: https://wpml.org/documentation/theme-compatibility/divi-builder/#translating-divi-global-items

Further, the issue needs debugging so could you please provide me a backup of your site, so I can replicate the issue on my end and see how the footer is being displayed.

To send a backup file you can use backups plugins, or use hosting services back up and send it using google drive, Dropbox, etc to us. If you can, I request you to remove the uploads folder from the backup as it will be easy to download due to the size.

I have enabled the private reply so you can send those links in the private reply. If you use some backup plugins installed and you created the packages, you can just provide login details and mention us, we can download it from the site itself.
hidden link

Look forward to your reply.

Thanks

July 8, 2019 at 1:30 pm #4162925

nadineL-4

Hi,

I resolved the problem. I gave the translation the suffix "EN" (for english) and that was causing the troubles. So if you translate such things, don't touch the title. Did you do anything that needs to be undone or can I just continue like it is?

Thank you for you help anyway!

July 9, 2019 at 2:48 am #4166885

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Glad to know it's working.

Did you do anything that needs to be undone or can I just continue like it is?

No there is no such thing that needs to be undone, you can continue.

Kind Regards,
Shekhar