This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 3 voices.

Last updated by Yvette 1 year, 5 months ago.

Assigned support staff: Yvette.

Author Posts
April 19, 2018 at 9:21 am #1685498

roosS

I am trying to: re-registrate WPML (with key)

Link to a page where the issue can be seen: holidaysdolomites.com

I expected to see: plugins re-activated

Instead, I got: invalid site key for the current site

In a response to the debugging action of a couple of weeks ago, I've reported that after the debugging my wpml menu (and most of the plugins) were not visible anymore ... It seems the registration was de-activated while debugging... I can't re-activate it myself. The key is not accepted while it is valid ! See screenshot.

April 19, 2018 at 9:51 am #1686081

roosS

Update, I registered the https version of my website in my WPML account and received a new license key which is now accepted. However, if I want to configure the WMPL CMS management plugin I get this error message: "sorry you are not allowed to access this page....".

It is the same message for which the debugging started a couple of weeks ago when WPML CMS was blocking access to wordpress admin...

April 20, 2018 at 1:33 pm #1725600

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Roos,

Thank you for contacting WPML Support. Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Please make sure minimum requirements for WPML:
https://wpml.org/home/minimum-requirements/

Also make sure you are using updated WordPress, Plugins and Theme.

Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Sixteen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

April 21, 2018 at 3:05 pm #1742448

roosS

Hi, I can't provide a debug report, I don't have a WPML menu with a support option (see screenshot). Another issue is that I am not allowed access to CMS management. If you read the previous tickets you have the full story. This seems to be the result of a debugging operations of one of your bots. Thanks

April 23, 2018 at 11:36 am #1766259

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Okay, please provide temporary access (WP-Admin & FTP) to your site so I can see your setup – preferably to a test site where the problem has been replicated if possible..

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

April 25, 2018 at 8:46 am #1804651

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Roos,

You FTP just showing me .sql files but not showing me staging site files as you can see in attached screenshot. I will need to have staging site FTP access to debug this issue.

I have enabled private message box, please provide temporary access (FTP Login info) to your test site so I can see your setup.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

April 26, 2018 at 8:48 am #1827876

roosS

Oh and yes, you have my permission permission to de-activate and re-activate Plugins and the Theme, and to change configurations in the staging 3 version of the website. Good luck with your operation !

April 26, 2018 at 1:08 pm #1835993

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

FTP login that you have provided is not working, Can you please provide me working login please. I have enabled private message box for your next reply.

Thank you

April 27, 2018 at 3:25 pm #1864331

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Roos,

I have thoroughly debugged your site and this issue. I have found out that there is something wrong in database table or database records were corrupted somehow.

1. I changed table_prefix value to 'test_' (table_prefix = 'test_') in the wp-config.php file and this way I have installed a fresh WP in the same database. Now all issues are gone and all the WPML plugins are working perfectly fine.

I have reverted all the changes and this is your older table prefix:

table_prefix  = 'gr3f_' 

You can also test this by changing table_prefix value in the wp-config.php file to 'test_'

2. The above experiment clearly indicates that there is something corrupted in original WP database tables in your site. And as soon as we install a new WP installation, all plugins and theme is working fine including WPML.

So we recommend to either fix the WP installation or install a fresh WP site and move your site content, plugins and themes there manually using WordPress export xml tool.

Thank you

April 28, 2018 at 10:03 am #1874708

roosS

Hi Noman, first of all many thanks for your help. I was already afraid that some tables/records were corrupted.

Now, I've changed the table_prefix to 'test' and see your clean 'test database'. I would like to use this clean environment of the staging copy, add my tables and push this website to live when finished.

Can I leave the table_prefix to test always ? Will it not pose any problems ? Can you give me some clear instructions about this ?

Thanks again for your great support !
Roos

April 28, 2018 at 1:12 pm #1875534

roosS

Hi Noman,

I've tried to export and import my files but without a lot of success, not all was imported and what was imported had all languages mixed up in the English (soure) language tab (there are four languages, two of which are archived). There's a lot of content in different posts and post types (tours, accommodations, locations)

I tried with WP All Import as well but I am afraid I don't understand very well how it works. So I decided to purchase the pro version (which was recommended) but I didn't get to the end of the paiment process... somehow the procedure/pages got stuck.

1) Is there another way to import the files more easy (for instance po-files) ?

2) If I buy the WP All import pro add on, could you or someone else support do the import for me ? It would be some much more efficient.

3) Now my languages are in different directories, can I change that to different domains per language later or should I do that immediately now ?

Thanks for your replies,
Roos

April 30, 2018 at 1:34 pm #1898495

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Roos,


Can I leave the table_prefix to test always ? Will it not pose any problems ? Can you give me some clear instructions about this ?

>> Yes, you can use ‘test_’ prefix or some other more secure prefix. We recommend not to use default(wp_) prefix to protect your database from spammers, hackers run automated codes for SQL injections. We can change table prefix very easily by following below doc:
hidden link

You can import your posts/pages using WP All Import and the WPML All Import Add On. Here are instructions to walk you through the process: https://wpml.org/documentation/related-projects/wpml-all-import-plugin-website-import-with-wpml/

Please note that if you have already imported the posts and pages in one language, you will need to re import them so that you can map the secondary language(s) to the original import using the same unique identifier (as explained in the link above).

2) If I buy the WP All import pro add on, could you or someone else support do the import for me ? It would be some much more efficient.
>> We recommend contacting one of our certified service providers for such cases:
https://wpml.org/documentation/support/wpml-contractors/


3) Now my languages are in different directories, can I change that to different domains per language later or should I do that immediately now ?

After taking backup, you can change it anytime from WPML >> Languages and then saving the permalinks.
This will move all URls automatically to the new setup and change them.
If any single page does not show up correctly after the change, because it may have been using a custom slug or there are any hardcoded slugs, they can be corrected manually.
We have some documentation about setting up WPML with different domains that will help you to understand possible issues.
You can check one of our documentation pages that covers the subject here: https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Thank you

May 7, 2018 at 6:50 pm #2019334

roosS

Hi Noman, thanks for all your work. One thing is not really clear to me, do I need to go through all these steps related to the table prefix exactly as shown in this video, the link you've send me ? hidden link

I did not do that and receive configuration errors after export/import and trying to look at imported files. Sorry for the question but I am a real WPBeginner 😉

Thanks for your reply,

May 8, 2018 at 7:08 am #2024243

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Roos,

You do not need to follow all steps from that link, If you want to change table prefix anytime then you can follow similar steps that describe in video.

Can you please select ‘default’ option and hit ‘Save Changes’ button from Settings >> Permalinks and see if this resolve your issue:
https://codex.wordpress.org/Settings_Permalinks_Screen

Thank you

May 16, 2018 at 9:08 am #2153128

roosS

Hi Noman,

I'd like to report that WP Export Pro and WP Import Pro do not support multilingual export/import. I've contacted the creators of
the add ons Soflyy and they confirmed this. This means that there's loads of work to do to reconnect the different languages... It will take me weeks.

I have one last question, you've changed the table prefix to test. I kept it as such. Now in my SQL database I see two types of tables, some with prefix test and a lot still with the old table prefix (gfr3). When I have finished transferring all data can I safely remove all the tables with prefix gfr3 ?

Thanks for your reply, Roos