This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Bigul 5 months, 3 weeks ago.

Assigned support staff: Bigul.

Author Posts
April 3, 2019 at 6:05 am #3522721

sofieC-2

Hi,

I have selected "Use WPML's Classic Translation Editor" for new content under WPML > settings and when I'm in a draft post in the default language and click translate to go to the draft of the same post in the translation, it opens in the Gutenberg block editor.
It doesn't open in the Advanced Editor which is something already but I just want to translate in the old, classic, html editor. Not in the block editor.
I know I can switch manually but that's annoying.
Is there no way to have WPML open the classic editor automatically for translations?

Thanks

April 3, 2019 at 1:55 pm #3526779

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please visit WPML>>Settings and make sure *Use WPML's Classic Translation Editor* option is selected in *How to translate posts and pages* section. Check the attached image for more details.

If so, please create a new Post or Page then make sure *Use WPML's Translation Editor* option is on in Language widget(on the right side of Post/Page Edit screen).

--
Thanks!

Bigul

April 3, 2019 at 2:41 pm #3527411

sofieC-2

Hey Bigul,
Like I said, I already have it selected to use the classic editor.
I do not wish to use the Advanced editor.
I just want it to work the way it did before the gutenberg update and the advanced editor.

Thanks

April 3, 2019 at 7:00 pm #3529933

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. We have released a new version of WPML(4.2.5). Please upgrade to the latest version after a full site backup and make sure the issue is existing or not.

--
Thanks!

Bigul

April 9, 2019 at 6:53 pm #3570101

sofieC-2

Still not able to download the update in WordPress.
Prefer not to upgrade to a beta.

April 10, 2019 at 8:24 am #3573419

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. WPML 4.2.5 is the latest version and it is not beta. Maybe you will be having this issue because of the caches.

Please try the following steps after a site backup and check you can upgrade WPML to 4.2.5 version or not.

1) Visit Plugins list
2) Click on *Add New* button
3) Click on the *Commercial* tab
4) Then press on *Check for updates* button

Please check the attached images for more details.

--
Thanks!

Bigul

April 13, 2019 at 8:13 pm #3605531

sofieC-2

I'm currently traveling.
Please give me a few days to look into this.

April 14, 2019 at 4:34 pm #3608391

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the update. Take your time. We will wait for your feedback.

--
Thanks!

Bigul

April 22, 2019 at 4:37 pm #3657067

sofieC-2

Okay I did the above and I can see that there are updates, but for some reason they are still not showing as updates in my plugin list. I'm sure this isn't a caching thing as I've cleared caching everywhere for other things I'm doing and other plugin updates are doing just fine.
So do I just check the boxes and select "download and activate"?

April 22, 2019 at 6:40 pm #3657903

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

April 23, 2019 at 6:09 am #3659721

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have requested access to check the current status of the WPML plugin. We will not make any changes in the site without clients permission.

If we click on *Updates* button of *Plugin Commercial* page, it will refresh the WPML plugins repository and we can upgrade the plugin from there.

Also please make sure you have registered for the Automatic upgrade of WPML plugins. Please check the following documentation for more details.

https://wpml.org/faq/install-wpml/#register

https://wpml.org/faq/install-wpml/#receiving-updates

hidden link

--
Thanks!

Bigul

April 23, 2019 at 9:39 am #3661407

sofieC-2

I'm now seeing the updates in the plugin list.
I have all the correct settings; Guess they're just not rolled out for everyone at once?
I'll see if this does the trick and will get back to you.

April 23, 2019 at 2:36 pm #3664779

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It may be a compatibility issue. We have released a new version of WPML today(4.2.6) today. Please try with the latest version after a site backup and let me know your feedback.

--
Thanks!

Bigul

April 28, 2019 at 1:20 pm #3698129

sofieC-2

Still the same issue after the latest update

April 29, 2019 at 6:12 am #3700173

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. It requires further checking. So please fill the private details fields after a full site backup. We would like to access your site Dashboard.

--
Thanks!

Bigul

The topic ‘[Closed] WPML ignores setting to Use WPML's Classic Translation Editor for new content’ is closed to new replies.