This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I cannot translate a custom WP Bakery module from my theme. It's a Headline module from Fruitful code's Anaglyph theme.

Solution:
I have fixed this issue by replacing following attribute name:

<attribute>headline-title</attribute>

With:

<attribute>headline_title</attribute>

From WPML >> Settings >> Custom XML Configuration.

Then, Saved primary language page again and open secondary language pages in translation editor and now issue is gone as you can see in attached screenshot.
https://cdn.wpml.org/wp-content/uploads/2018/10/2863327-custom_headline_module.png?x59034

This topic contains 11 replies, has 2 voices.

Last updated by danielO-35 11 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
October 23, 2018 at 1:19 am #2840102

danielO-35

I am trying to: translate my wp bakery page
I was expecting to see different windows with my stuff in bakery as shown in your videos about it. yet all i got was NOTHING: I mean, clicking translate and only being able to translate the title.

Is either that or duplicate, which is exactly what I wanted NOT to do when I bought WPML
Thanks

October 23, 2018 at 2:04 pm #2842762

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please try the below procedure:

- Go to Plugins >> Add new >> Commercial >> and click on "check for updates"
- Edit the translation and finish it as it is (mark it as 100% Translated).
- Make a small change in the original page, for example, a space in your title.
- Edit the translation again.

Does it work this time? If still issue persists, please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

October 24, 2018 at 4:39 am #2844861

danielO-35

Hi. I resolved most of the issue. But I still have a problem with headline texts. WPML seems to be ignoring them completely. All the other modules show perfectly.
Could you also offer some guidance on how to use different images for the translated pages?
Thanks!

October 24, 2018 at 1:36 pm #2846531

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Here are WPBakery Page Builder modules that are supported by WPML and will automatically be displayed on the Translator Editor page:
https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/#supported-modules

And here is guide how to make custom VC element WPML translation editor compatible:
https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/
https://wpml.org/documentation/support/language-configuration-files/

Please let me know if this resolves your issue or you need further help in translating headline text and image translation.

Thank you

October 28, 2018 at 8:14 am #2856014
danielO-35

Hi. I realized that the module that I cannot translate is a costume wp bakery module from my theme and not a native wp bakery module. On the other hand, I couldn't make WPML compatible with it yet. It's a Headline module from Fruitful code's Anaglyph theme. It would be really great if you could help me with that if I'm still not able to fix it soon.

On the other hand I need help translating some pictures. How exactly do I make WPML let me select different pictures on the translated pages?
Thanks!

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/i-need-help-translating-some-pictures/

October 29, 2018 at 12:21 pm #2857878

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

For custom wpbakery module - Please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

How to Translate Images - I have created a new ticket for this since this is a separate issue. Here is the link to the new ticket: https://wpml.org/forums/topic/i-need-help-translating-some-pictures/

Thank you

October 30, 2018 at 10:57 am #2861324

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

WP login info you have provided is not working at my end, please check username / password is correct and send me the working logins. Your next reply will be private.

Thanks

October 30, 2018 at 6:39 pm #2863325

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Yes WP login is working now and I am working on this issue.

FTP is not working though.

October 30, 2018 at 6:48 pm #2863327

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks you for the login details. I have fixed this issue by replacing following attribute name:

<attribute>headline-title</attribute>

With:

<attribute>headline_title</attribute>

From WPML >> Settings >> Custom XML Configuration.
Then, Saved primary language page again and open secondary language pages in translation editor and now issue is gone as you can see in attached screenshot. Could you please check and confirm?

Thank you

October 30, 2018 at 6:49 pm #2863341

danielO-35

Try using hidden link. The other data is ok. I just tried and worked

October 30, 2018 at 7:16 pm #2863434

danielO-35

It appears to be working. Thank you!

October 30, 2018 at 7:18 pm #2863436

danielO-35

My issue is resolved now. Thank you!