This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bigul 1 month, 4 weeks ago.

Assigned support staff: Bigul.

Author Posts
August 16, 2019 at 7:37 am #4405249

vadimP

Hi,

We are using WooCommerce and 1C:Enterprise plugin to add products to our website. Products are added in 3 languages, main one is Latvian and also 2 translations - English and Russian.

The problem we have is that we can't synchronise stock quantities between the translations. We've tried syncing it through WooCommerce Multilingual > Troubleshooting – this didn't work because we need all stock quantities synced according to Latvian version. Latvian is the main language of the website and also the original language in which products are added (using the 1C:Enterprise plugin). Troubleshooting synchronises stock according to English version for some reason, even though it is not products' original language.

We suspect that WooCommerce and 1C:Enterprise plugin might be causing issues. We need to find a way to sync all stock quantities by the Latvian version, not English. Please let me know if there is a solution or if you need access to the website to look at it more closely.

Thank you.

August 16, 2019 at 3:16 pm #4407239

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following steps after a full site backup and make sure the issue is existing.

1) Upgrade to the latest version of the WPML plugins(4.2.7.1)

2) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://wordpress.org/support/article/editing-wp-config-php/#increasing-memory-allocated-to-php

3) Increase the *MaxInputVars* of PHP settings to *5000* or more. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

For your kind information, *1C:Enterprise* plugin is not listed on the WPML compatibility list for the Plugins - https://wpml.org/documentation/plugins-compatibility. It does not mean that this plugin is not compatible with WPML, but our compatibility team has not tested it yet.

--
Thanks!

Bigul

August 22, 2019 at 12:27 pm #4439245

vadimP

Hi Bigul,

Thank you for your response. We have implemented all changes that you suggested but it didn't solve the issue with stock quantity synchronisation between languages.

Could you please advise on further steps?

Thank you.

August 22, 2019 at 6:10 pm #4442141

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Also please let me know the steps to reproduce the issue on your site.

--
Thanks!

Bigul

August 23, 2019 at 4:15 pm #4448689

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following troubleshooting steps after a full site backup and make sure the issue is existing or not.

1) Upgrade to the latest version of WooCommerce(3.7.0) and WooCommerce Multilingual(4.6.5)
2) Go to WPML>>Languages>>Language filtering for AJAX operations
3) Enable *Store a language cookie to support language filtering for AJAX* option
4) Go to WPML>>Support page
5) Click on Troubleshooting link (blue link in the middle of the page)
6) In Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment
- Recreate ST DB cache tables

7) Then try the WooCommerce Multilingual troubleshooting steps

--
Thanks!

Bigul

The topic ‘[Closed] WPML integration with WooCommerce and 1C:Enterprise plugin’ is closed to new replies.