This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bobby 4 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
June 4, 2019 at 6:57 pm #3954733

jorgeT-7

I am trying to: n/a

Link to a page where the issue can be seen: hidden link

I expected to see: Only the translators I add

Instead, I got: somehow WPML adds users randomly as translators role. Im missing something on the settings?

June 4, 2019 at 8:57 pm #3955205

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I have registered on the site but i just see the expected screen for a WC user without the ability to translate.

when you go to WP->Users-> what is the role of "wpml_test" ? please send me a screenshot

June 5, 2019 at 3:43 pm #3962437

jorgeT-7

Hi!

Here's the screenshot.

So far no newly adde translators (I deleted around 100 yesterday).

June 5, 2019 at 5:32 pm #3963081

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

The checkbox i see in your screenshots is the notification checkbox, this doesnt allow the user to translate , it just serves as a notification in case you ever assign translations to them.

the notification "Send me a notification email when there is something new to translate" is a WPML Translator notification.

this notification serves its purpose only for Translators, adding a subscriber thus not a translator the notification will be checked but it will not send them an email.

you did mention that you delete around 100 translators therefore i am curious as how this could of happened as they would of needed to be added manually

June 6, 2019 at 3:22 am #3965661

jorgeT-7

Exactly!

This wasn't the first time this happened.

The main problem is when I assign a new translation to "the first one available" my customers are getting a notification mail

June 6, 2019 at 9:39 pm #3972285

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

For the translators they have to be manually added to the screen you shared with me in the previous post

and are your subscribers still getting a notification when you set a translation set to "the first one available" , i have set this on my enviroment but i can confirm i do not receive any notifications unless i am set as an author/editor or added as a translator within WPML->Translation Management-> Translators

is this behavior still happening on your site ? Did somebody else with Translation Manager access possibly add subscribers by accident as translators ?

if it continues happening we can migrate to our server and try to replicate the behavior as i am not able to replicate this behavior with a clean environment

NOTE : Please review the following note as if you have a custom plugin or any plugin that allows any of your registered users to "clone" or "duplicate"a post then this could be causing the issue

"If a user is allowed to duplicate a post, then he has the rights to translate and WPML automatically sets that user as a translator (a duplicated post is like any other translation).
Therefore, if a user duplicates a post, no matter how this happens, it means he is supposed to be a translator."

The topic ‘[Closed] WPML is adding registered users as translators’ is closed to new replies.