This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.43 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Andrés 2 years, 4 months ago.

Assigned support staff: Andrés.

Author Posts
May 4, 2017 at 3:04 pm #1268323

gentianG

Dear Support,

I would like to discuss with you possible solutions for my wordpress site installed on windows server.
I am using MultiPurpose - Responsive WordPress Theme
Everything starting from wordpress and plugins is in their latest versions.
PHP version 7.1.14 stable version.
During this time CPU used to load 100% of its processes, Php was faulting, and 70 % of RAM was consumed.
After i did an upgrade of PHP (v. 5.6) situation was improved. But it is still concerning as CPU in specific moments keeps loading 100%.
I have a dedicated server, as using 2 processors. ( adding a second processor was a solution to keep loading more stable)
My website is a really simple one, corporation site.
What would you suggest in this case?

Kind Regards,

May 5, 2017 at 9:52 am #1269026

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello there,

Welcome to WPML support forum.

As you have mentioned, Multilingual sites are known for being slower than regular sites because they performed more database calls. So, in order to improve this , we work hard in every WPML update. Are you using WPML 3.7.0 and experiencing an special impact with this upgrade?

On the other hand, we also wrote a post about performances issues with WPML, could you have a look at it? http://wpml.org/2012/01/can-your-site-run-faster/
Basically, we talk here about settings OFF the following, but please, read it carefully:
- Auto ID adjust state (WPML > Languages)
- Track where strings appear (WPML > String translation)
- Auto register strings (WPML > String translation)

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us:
http://wpml.org/faq/provide-debug-information-faster-support/

Best regards,
Andrés

May 9, 2017 at 10:52 am #1271606

gentianG

Hello Andrés,

I have provided debug information as requested.
According your advice, i will do necessary changes.

Thank you in advance,

Kind Regards,

May 9, 2017 at 3:03 pm #1271897

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Great, I'll wait for your results. In the meantime, you could consider to:

1. Could you please upgrade your PHP and MySQL versions? Your current versions are:
- PHPVersion 5.6.22
- MySQLVersion5.7.13

2. Could you please increase your memory RAM? Particularly, your WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:
- MemoryLimit 1024M
- WP Memory Limit 256M

Please edit your wp-config.php file and add the following line:

define('WP_MEMORY_LIMIT', '256M');

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

WPML Minimum Requirements:
https://wpml.org/home/minimum-requirements/

May 22, 2017 at 9:37 am #1281363

gentianG

Hello again Andres,

Thank you for your support, i have already increased memory limit via php.ini file, and it was 256 MB, as well we added on wp-config file as suggested from your side.
at the moment situation is stable (no changes after adding define('WP_MEMORY_LIMIT', '256M');)

In the future if we are going to have issues with server again we will request to reopen this topic.
Thank you for your support and your time.

Kind Regards,

May 22, 2017 at 9:56 am #1281402

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

I'm glad to know that your situation is stable now. 🙂

Kind regards,
Andrés