This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by Shekhar Bhandari 2 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 21, 2019 at 8:04 pm #4069077

ranieri-domenicoC

I am trying to: run my site without problems

Link to a page where the issue can be seen: hidden link
but also in the past two weeks the Language of the site continuosly changed from italian to english, randomly (i can see it only in the WordPress app, under the "activity" tab). After 3/10 minutes the Language reverted back again.
In one day I got this error about 4-10 times. After that started happening I started loosing about 30% of traffic.
No errors from gogle search console and than I recived this, just Yesterday:

------
Ciao!

WordPress 5.2 ha una funzionalità integrata che rileva quando un plugin o un tema provoca un errore irreversibile sul tuo sito e ti avvisa con questa email automatica.

In questo caso, WordPress ha incontrato un errore con uno dei tuoi plugin, WPML Multilingual CMS.

Per prima cosa, vai al tuo sito web (hidden link) e controlla se ci sono problemi visibili. Successivamente, vai nella pagina in cui è stato rilevato l'errore (hidden link) e verifica se c'è qualche problema visibile.

Contatta il tuo host per richiedere assistenza per una investigazione più approfondita di questo problema.

Se il tuo sito appare danneggiato e non puoi accedere normalmente alla tua bacheca, WordPress ora ha una speciale "modalità di ripristino". Ciò ti consente di accedere in modo sicuro alla tua bacheca per controllare cosa non va..

hidden link

Per mantenere il tuo sito sicuro, questo link scadrà tra 1 giorno. Non preoccuparti di questo: ti verrà inviato un nuovo link se l'errore si ripresenta dopo la scadenza.

Dettagli dell'errore
====================
Un errore di E_ERROR è stato causato nella linea 143 del file /home/ranieris/public_html/wp-content/plugins/sitepress-multilingual-cms/menu/post-menus/post-edit-screen/wpml-meta-boxes-post-edit-html.class.php. Messaggio di errore: Uncaught Error: Cannot use object of type WP_Error as array in /home/ranieris/public_html/wp-content/plugins/sitepress-multilingual-cms/menu/post-menus/post-edit-screen/wpml-meta-boxes-post-edit-html.class.php:143
Stack trace:
#0 /home/ranieris/public_html/wp-content/plugins/sitepress-multilingual-cms/menu/post-menus/post-edit-screen/wpml-meta-boxes-post-edit-html.class.php(57): WPML_Meta_Boxes_Post_Edit_HTML->translation_priority()
#1 /home/ranieris/public_html/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1976): WPML_Meta_Boxes_Post_Edit_HTML->render_languages(Object(WP_Post))
#2 /home/ranieris/public_html/wp-admin/includes/template.php(1304): SitePress->meta_box(Object(WP_Post), Array)
#3 /home/ranieris/public_html/wp-admin/edit-form-advanced.php(635): do_meta_boxes(Object(WP_Screen), 'side', Object(WP_Post))
#4 /home/ranieris/public_html/wp-admin/post.php(197): include('/home/ranieris/...')
#5 {main}
thrown

----

That was an automatic mail from WordPress 5.2.

Today I deactivated the plugin, hoping the traffic goes up againg.

Is there anything we can do about it? Thanks

June 24, 2019 at 5:56 am #4074779

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Which version of WPML plugins are you using? We recently released a new version of WPML translation management plugin which fixed the same issue on my test site, so could you please try to use the latest translation management plugin and let me know if this helps?

Look forward to your reply.

Thanks

June 24, 2019 at 5:43 pm #4079027

ranieri-domenicoC

Hi,

my versions are:
- WPML Multilingual CMS 4.2.7.1
- WPML Media 2.5.2
- WPML String Translation 2.10.4
- WPML Translation Management 2.8.5

How do I update them manually? I tried some days ago to update through WP but an error occurred. Thanks for the support!

June 25, 2019 at 11:30 am #4083963

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To update manually, please follow the below steps:

❌ Backup your website and database ❌
• Deactivate/Delete the “Installer” plugin (if you have it)
• Deactivate all WPML plugins
• Login via FTP to your wp-content/plugins folder
• Delete all WPML folders
• Go to http://wpml.org/my-account/downloads/ and download the latest stable WPML Multilingual CMS Plugin, then extract it.
• Upload the plugin via FTP to the wp-content/plugins folder.
⌥ alternatively you could upload the .zip file using Dashboard > Plugins > New > Upload
• Activate the WPML plugin via WP Dashboard > Plugins
• Complete the setup, if needed
• Register WPML for your site (at the end of setup, click on “generate key” button)
• Navigate to Dashboard > Plugins and locate WPML Multilingual CMS
• Click on the blue link that says “Registered”
• Download and activate all needed WPML AddOn Plugins

This should not generate any problems.

⌥ In case you want to register WPML for your site manually please make sure to enter the naked URL of your site in wpml.org (something like hidden link)

⌥ In the extreme case, please try to register with all non-WPML Plugins deactivated,
and Theme Twenty sixteen enabled.

Let me know if this helps.

Thanks

July 7, 2019 at 7:41 pm #4158137

ranieri-domenicoC

Hi,
I did all this, but the day after I saw again my website language changed. I deactivated again the plugins 🙁

July 8, 2019 at 4:39 am #4159023

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the details.

Could you please explain a bit more about the language change? So I can help?

Also, could you please provide me login details so I can quickly check once you provide that information? for this, I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

July 9, 2019 at 2:58 am #4166965

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The error I get is visible only from the mobile android app of wordpress, under the menu "acitivity" or "logs" (in italian is "attività").

So this is happening on the backend, are the users able to see this in front-end? if so can you please provide me a screenshot or link so I can debug this further.

That happens randomly, with the constant that the original language of the website is italian and than it change back in italian just after some minuts it is setted in english.

Are you trying to tell me that the default language of the site is changing randomly without you making any changes?

Look forward to your reply.

Thanks

July 9, 2019 at 10:39 am #4169701

ranieri-domenicoC

I saw only the change in the backend, not in the frontend, but I don't exclude it could happens.

Yes, the default language, is changing randomly without me making any change.

July 10, 2019 at 9:37 am #4177809

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, the default language is changing randomly without me making any change.

Do you have any steps you remember to reproduce this?

You mentioned it happens only in the backend, do I need to use WordPress add or it's visible by visiting the site from the browser too.

Also, you have wpml disabled at the site, is it ok, If I enable WPML to debug it further?

Look forward to your reply.

Thanks

July 10, 2019 at 10:11 pm #4184647

ranieri-domenicoC

To reproduce this error you have only to activate the plugins and wait.
I haven't found the error in the browser but Simply maybe because I don't know where to look at. In the First message i Copied and pasted the error I got from Jetpack automatic errors detector, but i wasn't anale ti find a log in the backend of the WordPress Page.

It's fine if you try to reactivate the plugins. Take some days to find out what's happening. It's very frustating because i paid for that and i lost lot of traffic and with It an income 😔

July 13, 2019 at 7:31 pm #4204059

ranieri-domenicoC

Hi,
I started the migration process. I will update you asap.
Thanks!

July 14, 2019 at 9:07 am #4205297

ranieri-domenicoC

Hi,
I inform you that the process Is completed.
Thanks

July 15, 2019 at 5:06 am #4207089

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for the migration.

I enabled the WPML plugin and can see the Italian as the default language, I have enabled the debug log so I will keep checking the site to see if the default language will be changed.

Also, if you have a better suggestion to catch the issue, I will be happy to hear it.

Thanks

July 15, 2019 at 11:30 am #4210489

ranieri-domenicoC

Unfortunatly I cannot be more useful.
Waiting your update.

Thanks

July 16, 2019 at 4:01 am #4215885

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am still monitoring the site and I couldn't notice any language change at all, the login details are same for the migrated site, so do you mind performing changes that you do normally on your site and let me know if you can reproduce it?

Look forward to your reply.

Thanks

The topic ‘[Closed] WPML is broking my website? WordPress 5.2 automatic error detected’ is closed to new replies.