This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 16 replies, has 2 voices.

Last updated by Riffaz 1 year ago.

Assigned support staff: Riffaz.

Author Posts
September 27, 2018 at 10:15 am

Pedro Henriques

I am trying to: use WP Job Manager and when WPML activated the breadcrumbs show up the Translation Priority instead of the home page of the listed jobs

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: hidden link

September 28, 2018 at 8:47 am #2772957

Pedro Henriques

In particular is the WPML Translation Management plugin.

The WP Job Manager is WPML certified (https://wpml.org/plugin/wp-job-manager/).

Looking forward for a solution.

Thanks,

Pedro

September 28, 2018 at 11:38 am #2773620

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support forum.

I could not check your site since the credentials you've provided are incorrect: hidden link

I think this may depend on how the breadcrumbs are being generated.

If they’re being created by your theme, you’ll need to consult that theme’s documentation on how to alter them. Without a link to your site, though, it’s hard for me to tell how/why those breadcrumbs are there.

I would ask your theme author in any case and see what they say.

Anyhow as per the plugin documentation, you have to define your job base and the other URLs.
Please refer: hidden link

By the way, The base URL for jobs cannot be the same as an already-existing page.
Let's say if you already have a page with jobs/career you can not set them as your job base URL.
The solution is to "choose a URL base that doesn’t have a page by that name"

Let me know.

Regards,
Riffaz.

September 28, 2018 at 1:31 pm #2774073

Pedro Henriques

Hello, Riffaz

Try again to login. My error, the user was blocked.

The issue only exists after activating WPML Translation Management plugin.

Thanks

October 1, 2018 at 8:58 am #2777498

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

In order to help you better I need to debug this issue locally, for this I'll need to temporarily install a plugin called "Duplicator" on your site. This will allow me to create a copy of your site and your content.
Once the problem is resolved I will delete the local site.
I hope this okay?

Regards,

October 1, 2018 at 9:09 am #2777521

Pedro Henriques

Hello, Riffaz

No problem. Anyway, if you would like, you cab test in the site I sent you. It's a staging site.

Regards

October 2, 2018 at 11:51 am #2781298

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Pedro,

I am trying to replicate the issue from the scratch on our localhost and I will get back to you soon.
We can identify the issue more accurately in a minimal setup.

Regards,

October 2, 2018 at 12:00 pm #2781303

Pedro Henriques

Ok, Riffaz

Looking forward for your feedback.

Regards

October 4, 2018 at 7:58 am #2786608

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link, you will be automatically logged in. If nobody logs in the test site will be available for one week from today.

Could you please install the Impreza theme and activate it there?
Install the WP Job Manager.
And, create a job with those elements and see if the issue is replicable on a clean WordPress installation breadcrumb?

Please configures WPML to the default language that is configured on your site and add your second language.

Please also make sure that you are installing the latest version of the Impreza and WP Job Manager.

In this way I can escalate this to compatible team and do the proper testing.

Regards,

October 4, 2018 at 1:54 pm #2787733

Pedro Henriques

Hello, Riffaz

Done.

I've created 2 jobs:

hidden link
hidden link

and the issue is showing up: hidden link

I hope you can fix it quickly.

Thanks

October 5, 2018 at 11:03 am #2790476

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the contact details you provided.

I will forward the details to our Themes & Plugins Compatibility Team and they will contact the author.
Please note that this process may take a while as it depends on how soon the author will reply to our efforts to contact him.

Regards,

October 8, 2018 at 1:10 pm #2796096

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Pedro,

The problem exists between Impreza theme and CPT (WP job manager is not needed)
CPT - Custom Post Type

We are working on the issue meanwhile as a workaround if you will select Job Type for the job then it works.

You have to enable the Job Type : hidden link
After you enable it you can select it here : hidden link

You will see the correct breadcrumb after you've selected that: hidden link

Let me know.

Regards,

October 8, 2018 at 1:33 pm #2796137

Pedro Henriques

Riffaz,

That doesn't work either.

Yes, I see the correct breadcrumb but when i click the Jot Type in the breadcrumb it goes to the Home page, not the Job Type selected.

Check for your self from the staging site: hidden link

Should I contact the theme developer to check it also?

Thanks

October 9, 2018 at 6:13 am #2798339

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Pedro,

It goes to the home page when we click on the Job Type in the breadcrumb even WPML is not activated.
so clearly it is not a WPML related issue.

So, yes, please contact the Theme support and WP Job Manager support regarding this.

Let us know if they give you any solution.

Regards,

October 11, 2018 at 11:01 am #2807732

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi Pedro,

We've contacted the theme author and he notified us he will fix this issue in next update.

Meanwhile, we came up with this workaround for you
Go to your hosting site installation and find \themes\Impreza\framework\functions\breadcrumbs.php and find Line 97 then replace

if ( $taxonomy_names != NULL ) {
                    foreach ( $taxonomy_names as $taxonomy_name ) {
                        $post_taxonomy = get_the_terms( get_the_ID(), $taxonomy_name );
                        if ( is_array( $post_taxonomy ) AND count( $post_taxonomy ) > 0 ) {
                            $post_taxonomy = $post_taxonomy[0];
                            $get_term_parents_args = array(
                                'separator' => $delimiter,
                                'link'      => TRUE,
                                'format'    => 'name',
                            );
                            $post_taxonomies = get_term_parents_list(
                                $post_taxonomy,
                                $taxonomy_name,
                                $get_term_parents_args );
                            $post_taxonomies = preg_replace( "#^(.+)$delimiter$#", "$1", $post_taxonomies );
                            $post_taxonomies = str_replace( '<a', $before . '<a' . $link_attr, $post_taxonomies );
                            $post_taxonomies = str_replace( '</a>', '</a>' . $after, $post_taxonomies );
                            $output .= $post_taxonomies;
                            $taxonomies_found = TRUE;
                            break;
                        }
                    }
                }

with

if ( $taxonomy_names != NULL) {
                    foreach ( $taxonomy_names as $taxonomy_name ) {
                        if ($taxonomy_name != 'translation_priority') {
                            $post_taxonomy = get_the_terms(get_the_ID(), $taxonomy_name);
                            if (is_array($post_taxonomy) AND count($post_taxonomy) > 0) {
                                $post_taxonomy = $post_taxonomy[0];
                                $get_term_parents_args = array(
                                    'separator' => $delimiter,
                                    'link' => TRUE,
                                    'format' => 'name',
                                );
                                $post_taxonomies = get_term_parents_list(
                                    $post_taxonomy,
                                    $taxonomy_name,
                                    $get_term_parents_args);
                                $post_taxonomies = preg_replace("#^(.+)$delimiter$#", "$1", $post_taxonomies);
                                $post_taxonomies = str_replace('<a', $before . '<a' . $link_attr, $post_taxonomies);
                                $post_taxonomies = str_replace('</a>', '</a>' . $after, $post_taxonomies);
                                $output .= $post_taxonomies;
                                $taxonomies_found = TRUE;
                                break;
                            }
                        }
                    }
                }

hope, this will help you.

Regards,