This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Carlos Rojas 3 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 14, 2019 at 7:56 am

guillaumeD-7

I am creating new pages and then I want to have their translations.
When trying to translate, I get the message that:
WPML is missing some records in the languages tables and it cannot fully work...

I have done what is explained on the following post:
https://wpml.org/forums/topic/wpml-is-missing-some-records-in-the-languages-tables-troubleshoot-didnt-work/#post-1189836

But after reseting WPML, in the section "Pages", I only see the German pages but all other pages are lost. It display 0 for English and 0 for French.

When trying to edit the page, I see that the translated pages are still existing but there is some link broken. Also on the website, only the German language is displayed but not anymore the other languages.

I restored the website now and I still see the WPML issue.

I have also increased the memory limit to 256MB in the wp_config.php file.

Could you help?

June 14, 2019 at 8:57 am #4019665

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

In this case I would like to ask your authorization to apply the steps in the live and and if necessary to make a copy of the site to keep running tests in a test environment.

Please create a full backup of the site before giving me the authorization.

Kind regards,
Carlos

June 14, 2019 at 12:43 pm #4021537

guillaumeD-7

Hello Carlos,

The backup is done using WP Clone.
So please apply the steps live, hopefully without breaking the website for too long as it is a corporate website.

Guillaume

June 14, 2019 at 8:28 pm #4023997

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your authorization.

I have applied some troubleshooting steps and the error message is still there but everything seems to be working now.

In order to rule out that this message has only get stuck in the database I would like to ask you to double check if you can see any other issue related to WPML in the site.

Looking forward to your message.
Regards,
Carlos

June 14, 2019 at 9:18 pm #4024223

guillaumeD-7

From the page called mobile, I have duplicated into French & English.
Then I have created a new menu called "Partners".
When looking at the section Page again, there is still an icon "+" displayed in both french and English as if no page were created.
Any idea why?
How is it possible to have the warning disappear?

Thanks

June 17, 2019 at 8:50 am #4033453

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Guillaume,

I took another look at the site and I just saw that WPML is outdated. Please create a full backup of the site and update WPML plugins in Plugins -> Add New -> Commercial tab.

Once the update is finished, does the issue persists?

Note: Outdated functionalities can cause conflicts in the code.

Looking forward to your message.
Regards,
Carlos

June 17, 2019 at 11:48 am #4035055

guillaumeD-7

Hi Carlos,

I have updated WPML but the issue is still persisting. I still have the WPML warning.
WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.

Thanks,

Guillaume

June 17, 2019 at 11:55 am #4035127

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Guillaume,
Thank you for your message.

I'm consulting our specialists about this issue and I will get back to you as soon as I have an answer.

Regards,
Carlos

June 17, 2019 at 12:13 pm #4035201

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Guillaume,

I would like to ask you to follow this steps:
- Create a full backup of the site.
- Connect to the database -> wp_options table (if 'wp' is the prefix of the database tables) -> Search and rename wpml_notices once.

Does the error appears again?

Note: If the message disappears then it was just stuck in the database. If the error message re-appears then there is a real issue in the database and I will have to make a copy of the database for further analysis.

Regards,
Carlos

June 17, 2019 at 1:06 pm #4035415

guillaumeD-7

Hello,

Thanks, I did not understand the exact action I need to take.
In the wp_options table, I need to search "What" ? And rename by "What"?

Thanks,

Guillaume

June 17, 2019 at 1:14 pm #4035543

guillaumeD-7

My tables starts with wor6288_options

Is it ok?

June 17, 2019 at 1:18 pm #4035577

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Guillaume,
I'm sorry if I wasn't clear in my previous message.

The steps to follow are this:
- In the 'wor6288_options' table -> Search for the option name 'wpml_notices' -> Edit the 'wpml_notices' and rename it with something like 'wpml_notices_old' -> Save the changes.

Then check if the error message re-appears in the backend of the site.

Regards,
Carlos

June 17, 2019 at 1:30 pm #4035665

guillaumeD-7

Hi,

I do not have this option name in my options table.
See attached.

I am not sure of disabling the notice triggering is a good option or only a workaround on the real issue.

Regards,

Guillaume

June 17, 2019 at 1:32 pm #4035689

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your feedback.

The steps recommended were to isolate the cause of the issue. It seems there is a real problem in the database and not only a stuck message. I would like to ask your authorization to make a copy of the site in order to run further tests in a local environment.

Regards,
Carlos

June 17, 2019 at 1:34 pm #4035701

guillaumeD-7

Yes please go ahead with a local environment to run further steps.

Thanks,

Guillaume