This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am trying to get WPML installed..I'm getting "WPML is missing some records in the language tables..." error

Solution:- Finish the WPML installation. - Go to WPML -> Support -> Troubleshooting link -> Reset section -> Select 'I am about to reset all translation and language data.' option -> Click on 'Reset and deactivate WPML' button. - Activate and setup WPML again.

Relevant Documentation:

0% of people find this useful.

This topic contains 10 replies, has 5 voices.

Last updated by Maria 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 25, 2018 at 5:13 am #2762494

maargiev

I am trying to:

get WPML installed..

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

September 26, 2018 at 1:49 am #2765478

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

If possible please run the following script within your theme's functions.php file.

=> https://wpml.org/errata/missing-_icl_strings-_icl_string_translations-data-tables/

if you are not comfortable running this script please let me know and i will be able to access your site and perform the script for you

let me know your results

September 26, 2018 at 1:56 am #2765480

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us.

Have you done any translation? If not, you can try resetting WPML and installing it again. To do this follow the steps below:

- Click on the WPML > Support > Troubleshooting
- Look at the "Reset"
- Check the "I am about to reset all translation and language data." option
- Click on the "Reset and deactivate WPML" button

After that, configure WPML again and see if the problem persists. Note: You must follow the above steps if you have *not* done any translation.

Please, let me know if the problem persists.

Thank you.

September 27, 2018 at 11:37 pm #2771970

maargiev

Hi there, Thanks for your reply. I tried both options, and even re-installed the plugin. Now I don't seem to be able to get in the languages field..it's just blank..with only the error message.

September 28, 2018 at 3:58 pm #2774370

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
My name is Carlos and I will be taking this ticket from now long.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Looking forward to your answer.
Best regards,
Carlos

September 30, 2018 at 4:02 pm #2776642

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

I would like to ask you to follow this steps:
- Finish the WPML installation.
- Go to WPML -> Support -> Troubleshooting link -> Reset section -> Select 'I am about to reset all translation and language data.' option -> Click on 'Reset and deactivate WPML' button.
- Activate and setup WPML again.

Could you tell me if the issue is solved?

Best regards,
Carlos

October 1, 2018 at 9:22 am #2777544

maargiev

Hi Carlos,

Thank for your help this seems to resolve the issue.

SITE DOWN!
However there were some issues with elementor header so I deactivated the plugin. I then uploader string translations and ..now my site is unreachable! I cannot even get in the dashboard..!

please advise
Thank you

October 1, 2018 at 7:02 pm #2779233

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I fixed the issue in the site, then I followed the steps I provided in my previous message and now you can setup WPML.

Could you confirm that the issue is solved?

Best regards,
Carlos

October 2, 2018 at 1:04 am #2779730

maargiev

My issue is resolved now. Thank you Carlos!

October 2, 2018 at 1:38 am #2779736

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos

July 17, 2019 at 1:58 pm #4230907

Maria

I have a new WP setup with 5.2.2, and only the WPML Multilingual CMS plugin. I receive this error message again and again... Have tried to reset it, remove it and install it again with no result.