This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by Arnaud 4 years, 3 months ago.

Assigned support staff: Dat Hoang.

Author Posts
June 24, 2015 at 11:37 am #645195

sebastienL-11

I am trying to: Use the plugin

I expected to see: Plugin options

Instead, I got:

WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.
Please go to the Troubleshooting page and click on Fix languages tables to fix this problem.

This warning will disappear once this issue is fixed.

June 25, 2015 at 8:20 am #645942

Dat Hoang

Your WPML versions are up-to-date (WPML 3.2.2 and its add-ons).

#1,
Please take a screenshot to show this message and share it with me?

#2,
If this is the first time you install WPML, please go to WPML > Support > Troubleshooting page > Scroll down and click "Reset"

Then please activate and install it again. Does that help?

#3,
If #2 does not help, do the same #2 but you disable all non-related WPML plugins - keep WooCommerce active, switch to one of default themes, then try again?

NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

June 25, 2015 at 10:24 am #646106

sebastienL-11

Hello,

Thank you for the reply.

#1 --> Has been attched attached here.
#2 --> Tried and not working.
#3 --> Tried and not working.

Awaiting your next reply.
Thank you.

June 26, 2015 at 3:55 am #646694

Dat Hoang

Thanks for your info.
I need to request temporary access (wp-admin and FTP) to your site in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only.

Note that:
+ Backup (both files and database) your site before giving us your credentials
+ It would be better if you give me the test site rather than the live site.

June 29, 2015 at 8:00 am #648134

Dat Hoang

I followed the instruction and click "Clear language information and repopulate languages" .
The problem no longer exists.

You can reinstall WPML.

Can you confirm that?

NOTE:
I installed two plugins: Adminer and BackupWordPress for saving your database, please remove them if you want.

June 29, 2015 at 8:52 am #648184

sebastienL-11

Hello.

Thank you.
But the problem is still here.
I will reinstall the plugin and let you know in a few minutes.

June 29, 2015 at 9:02 am #648196

sebastienL-11

"WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.
Please go to the Troubleshooting page and click on Fix languages tables to fix this problem.

This warning will disappear once this issue is fixed."

I just did the steps that you told me in your latest comment but the problem is in fact still here.

June 30, 2015 at 2:50 am #648941

Dat Hoang

I found the problem why "Reset" and "Clear language information and repopulate languages" do not work.

After running these buttons, WPML custom tables are still there.
The reason is that your current MySQL user has no permission to run DROP commands.

Error in query (1142): DROP command denied to user 'u7xb4****'@'localhost' for table 'wp_icl_flags'

You should edit the privileges for this MySQL user and try again.
That should help.

June 30, 2015 at 6:00 am #649002

sebastienL-11

Tried it and it was in fact the privileges.
No error messages can be seen now.

Thank you very much for the assistance.

September 30, 2019 at 5:08 am #4662333

Arnaud

I am trying to: Use the plugin

I expected to see: Plugin options

Instead, I got:

WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.
Please go to the Troubleshooting page and click on Fix languages tables to fix this problem.

This warning will disappear once this issue is fixed.