This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bobby 4 months ago.

Assigned support staff: Bobby.

Author Posts
June 10, 2019 at 9:18 pm

jean-michelP-2

Always have the problem.

I try to disable all non wpml plugin, re-install.....and the error message was still there.

My configuration:
PHP
Version 7.2.19
Memory limit 268435456
Memory usage 18.32 MB
Max execution time 600
Max input vars 1000
Utf8mb4 charset Yes
WordPress
Version 5.2.1
Multisite No
Memory limit 40M A memory limit of at least 128MB is required.
Max memory limit 256M

June 11, 2019 at 1:06 am #3990877

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi there,

is this a fresh install of WPML(meaning no previous work was done with WPML on this site ) or do you currently have translations existing on the site ?

June 11, 2019 at 1:12 am #3990881

jean-michelP-2

Yes fresh new, no translation yet at this moment.

June 11, 2019 at 7:35 pm #3998297

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i test your site locally using duplicator and i was able to successfully install WPML without any errors.

additionally even after i have cleared the message manually from your database and made sure that the language tables are populate it remains which points me to a caching issue.

if possible please verify that your cache is cleared. If possible i would like to test with your cache cleared and deactivated let me know if the issue remains.

additionally please upgrade your WP MEMORY LIMIT to 256M or higher

if that does not resolve the issue you could potentially use the following debuging process to eliminate any issues caused by a 3rd party plugin but please note it is optional

-Back up your site first
-Deactivate all non WPML related plugins
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with wich one there is an interaction issue

Let me know your results please.

June 12, 2019 at 12:18 am #3998901

jean-michelP-2

I increased the memory to 256mb, I cleared the cache, reset the installation of WPML without success.

I also disabled caching, W3 total cache, and proceeded with a WPML reset.

I alsoDeactivate all non WPML related plugins & switch for a moment to a WordPress default and still have the error message 🙁

June 12, 2019 at 5:56 pm #4006717

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I believe i might have figured out what is causing this behavior.

After going to WPML->Support->Troubleshooting->RESET WPML , all WPML (wp_icl_) tables within the database should be dropped and removed from your database allowing you to start new.

what i am noticing is that if you examine your DB table there are still wp_icl_ tables present even after the RESET.

i did try to drop a table manually but i am denied access using your admin account therefore there is a chance you might not be able to write on your database or make changes

please verify that you can make changes and create tables within your database and verify with your host provider

=> https://wpml.org/home/minimum-requirements/

Also do note that on my local environment i was able to successfully install WPML using your duplicator package.

The topic ‘[Closed] WPML is missing some records in the languages tables and it cannot fully …’ is closed to new replies.