Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bobby 2 years, 9 months ago.

Assigned support staff: Bobby.

Author Posts
January 24, 2017 at 5:26 pm #1189676

craigS-7

I am trying to: Install WPML

URL of (my) website where problem appears: hidden link

I expected to see: WPML configuration page and the error message disappear

Instead, I got: "WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.
Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem.

This warning will disappear once this issue is fixed."

Steps to duplicate the issue: I followed the steps in the troubleshooting page several times with no effect.

January 24, 2017 at 8:17 pm #1189836

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

Thank you for contacting WPML Support,

Is this a new fresh install ? meaning that there are no translations existing correct?

Solution:
- Deactivate all non-WPML plugins.
- Reset WPML by following the steps below:
WPML >> Support >> Click on troubleshooting page link >> Scroll down to the end of the page >> Choose I am about to reset all translation and language data >> Click Reset

Please note that this solution works with WPML new installation only, since the reset option will delete all WPML tables and accordingly any translations you have on your website, if you have any.
-Reactivate all non-WPML plugins

January 24, 2017 at 10:02 pm #1189903

craigS-7

Thank you. That worked and WPML is now installed. However, now I have a new issue. I want the admin to be in English and the site in French. While the WordPress Admin is in English for some reason the WPML settings (only) are all in French. How do I fix this? I tried going into Users and assigning my admin language but that option isn't even available.

January 24, 2017 at 10:20 pm #1189909

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

You should be able to edit your profile and from within there set the language and WPML editing language
(view screenshot)

If this does not work then may i kindly ask you to please open a new ticket for the new issue.

Thank you!