This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WPML is not showing fields with only an URL for translation Solution: It is all about what advanced translation editor is filtering and as it seems, it is also filtering your URL field.

ATE development team is planning an extension for ATE to manually set filtered content and interact with it (translate), but ETA for this is somewhere near the end of the year.

The only way is by using the manual editor or the classic translation editor, so this is the only workaround I suggest for you at this point. Relevant Documentation: https://wpml.org/forums/topic/no-content-in-pages-in-other-languages/#post-3912089

This topic contains 6 replies, has 2 voices.

Last updated by Miquel Adell Borràs 2 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
July 11, 2019 at 9:38 am #4187973

Miquel Adell Borràs

I am trying to:
Translate an URL (the url is different in different langauges)

Link to a page where the issue can be seen:
hidden link

If you scroll to a place where the website of the highlighted project is shown (search for the word website) this URL should be translatable.

I expected to see:
The hability to translate this url

Instead, I got:
The origianl URL copied over.

I'm attaching 3 screenshots showing that the field is marked to be translated, that everything else is translated correctly and that the original catalan field dos appear when saving transalation but with no option to have that translated

July 11, 2019 at 1:59 pm #4190543

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

July 18, 2019 at 1:21 pm #4239055

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

No worries about the delay - however, I can see the issue and I have asked our 2nd tier for an opinion. Interestingly enough, since the username you provided did not have ATE access, I opened the translation in standard translation editor first and this field is visible here in fact.

So there could be something related to segmentation in advanced translation editor, for which 2nd tier will hopefully provide some information.

I will keep you posted!

Regards,
Bruno Kos

July 18, 2019 at 1:33 pm #4239115

Miquel Adell Borràs

I added the user "test" to Translation Management -> translation roles.

I hope that lets that user use advanced translation and it does help you debug.

Thanks!

July 18, 2019 at 1:39 pm #4239275

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I already did this (activated ATE for that user) and saw the issue, so no worries.

Regards,
Bruno Kos

July 19, 2019 at 12:57 pm #4246571

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Can you have a look at this answer?
https://wpml.org/forums/topic/no-content-in-pages-in-other-languages/#post-3912089

It seems like that the same issue is happening here - it is what advanced translation editor is filtering and as it seems, it is also filtering your URL field.

ATE development team is planning an extension for ATE to manually set filtered content and interact with it (translate), but ETA for this is somewhere near the end of the year.

The only way is by using the manual editor or the classic translation editor, so this is the only workaround I suggest for you at this point.

Regards,
Bruno Kos

July 23, 2019 at 6:34 am #4263043

Miquel Adell Borràs

Well, that'll have to do for now.

Thanks.