Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Client does not have an update button available while beeing looged in to Multisite

Solution: Please download the latest versions of WPML Multilingual CMS 4.2.5 at https://wpml.org/downloads. This installation has to be completed on the network site by a superadmin.

In case of installation issues: Deactivate and delete all WPML plugins. Do not worry, this process will not affect your translations and settings stored in the database.

Add WPML Mulitlingual CMS 4.2.5 again.

Then go to Plugins -> Install -> Commercial and download the add-ons. Also, select the "Enable After Download" button at the bottom of the plug-in selector.

Relevant Documentation: https://wpml.org/documentation/support/multisite-support/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by anneg-4 2 years, 7 months ago.

Assigned support staff: Andreas W..

Author Posts
April 5, 2019 at 5:30 pm #3546159

anneg-4

I am trying to: update WPML and Translation Management

Link to a page where the issue can be seen: The problem is in the WordPress editor for my site. I have a multisite with wpml and translation management only activated in the child site, not at the network level. I have php 7.2 and WordPress 5.1.1.

I expected to see: an update button

Instead, I got: my plugins appear to be up to date, but they are not

I copied my entire production site (www.wexinc.com) down to my dev server (wexincdev.wpengine.com). I want to update my 2 wpml plugins but there is no update button. There is also no place to enter my site key. Should I just manually replace the plugins via sftp on my server?

Capture.PNG
April 5, 2019 at 5:33 pm #3546185

Andreas W.
Supporter

Languages: German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

Please download the latest versions of WPML Multilingual CMS 4.2.5 at https://wpml.org/downloads.

Deactivate and delete all WPML plugins. Do not worry, this process will not affect your translations and settings stored in the database.

Add WPML Mulitlingual CMS 4.2.5 again.

Then go to Plugins -> Install -> Commercial and download the add-ons. Also, select the "Enable After Download" button at the bottom of the plug-in selector.

This installation has to be completed on the network site by a superadmin.

Please let me know if the issue has been resolved.

Kind regards
Andreas

April 6, 2019 at 6:39 am #3548509

anneg-4

My issue is resolved now. Thank you!