We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Laura 5 months, 2 weeks ago.

Assigned support staff: Laura.

Author Posts
May 28, 2019 at 6:35 pm

ricardoS-4

We develop a website in WordPress which uses Woocommerce and WPML for translations.
On top of it, we developed a custom product configurator in React which is a separate application, the only common link between the two is that it uses Woocommerce API to fetch product information.
On this custom application, we don't need translations and we're not using WPML API. We noticed the REST Api calls were too slow and so we tried to deactivate the plugins installed on the WP instance and we found that if we deactivate WPML the Woocommerce REST Api calls got significantly faster I've attached screenshots of those calls with and without WPML active.
Also, we're not using WPML to translate the products.

We want to understand why WPML is slowing down the API calls and how can this be fixed.

If needed we can provide access to the project so you can have a look and/or provide any additional information or reports from debugging tools.

May 29, 2019 at 3:25 pm #3916865

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

thanks for contacting us.

From your debug information, I see you're using MySQL 5.5.5 (unless you're using Maria DB instead). WPML requires at least version 5.6, so this could be an explanation.

Moreover, the WP Memory Limit needs to be increased. PHP memory limit is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb.
Add this near the top of wp-config.php file (after the php opening tag) to increase WP memory:

/** WP Memory Limit */
define( 'WP_MEMORY_LIMIT', '256M' );

The wp-config.php file is located in your WordPress root directory. It's the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
You can check the current WP Memory Limit value from WPML -> Support in the Info section
More info here:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP
https://wpml.org/home/minimum-requirements/

If these suggestions don't help, we'd need credentials and possibly a copy of the site. We suggest Duplicator plugin to do it. I'll enable a private reply.

The topic ‘[Closed] WPML is slowing Woocommerce REST API calls’ is closed to new replies.