This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.12 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: The user was having the site wide settings for Yoast(title, description) overwritten in other language after a few hours. Solution: The user has found that this is caused by Yoast, Yoast checks the company logo image and set the fields according to the logo language. Once he updated the logo the issue was resolved.

This topic contains 18 replies, has 2 voices.

Last updated by orenK-3 3 months, 2 weeks ago.

Assigned support staff: Jamal.

Author Posts
June 24, 2019 at 7:22 am #4075023

orenK-3

I am trying to:
We are updating the site title and site description in string translations.
Every day when we go to Yoast, something is replacing the Strings with a french ones.

June 24, 2019 at 3:14 pm #4078237

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

Could you please elaborate a little more on your question so I can better understand?
Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area.

Are you talking about the homepage or other pages?
Can you give a URL to see this page and check the title and description generated?

Finally, consider installing our glue plugin for Yoast from this URL
https://wpml.org/download/yoast-seo-multilingual/?section=changelog

Best regards,
Jamal
WPML Support

June 25, 2019 at 1:35 pm #4084971

orenK-3

Alright.

Full description of the problem.
We have a site in English - us-megamillions.com.
We used WPML to translate the pages/posts and everything to France, German and Spanish.
We have a problem with the Site Title and Site Description.
I am going to Yoast to set the English version of the Site Title and Site Description here:
hidden link

Then i going to WPML->String Translation and choosing in domains "admin_texts_wpseo_titles"

I am going to site title and site description and translate them to France, German and Spanish.

I go to the site, i see the site title and description in English,

Now finally the problem:
After a day, the site title and description is changing to France version and also i get "translation needs update here:

hidden link

June 25, 2019 at 1:38 pm #4084987

orenK-3

I again set the English version and i goes to Spanish site and again the title and description changed....

June 25, 2019 at 2:59 pm #4085677

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

Thank you for your feedback. Would you please check if this errata will resolve this issue.
https://wpml.org/errata/string-translations-disappearing-on-sites-where-default-language-is-not-english/
Please uncheck this option if checked "Assume that the original language of all strings is English". It is under WPML->Theme and Plugins Localization->Other options

If it does not, could you provide a clone website where we can test a minimal setup(only WPML plugins+default theme)? If not, I can provide a test server and give you the instructions to migrate your website there.

Best regards,
Jamal

June 26, 2019 at 7:01 am #4089693

orenK-3

Hi Jamal,

How are you?
I unchecked the option.
It's still doesn't work.

I got other problem that not working and might be connected.

Everytime i update the meta description in English(In Yoast), the translation is back from "Translation complete" to "Translation needs update".

June 26, 2019 at 11:20 am #4091917

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you:), how are you?
Have you been able to try in a minimal setup (only default theme+WPML extensions+Yoast)?

Can you provide a staging environment where we can test this?

Would you like me to create a test server on our infrastructure and migrate your website there, so we can troubleshoot this issue without affecting your live server?

Please also, let me know, from what screen exactly you have taken this screenshot hidden link

Best regards,
Jamal

June 26, 2019 at 4:02 pm #4093985

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

I just translated the site title in the staging site. And checked the French homepage, the title was correctly generated.
Let's see if tomorrow the title will change to anything, and if the complete translation will switch back to "translation needs update".

I also noted that the homepage uses the special template front-page.php, that uses the parent theme functions genesis();

But what I'll suspect first is the cache, maybe wpengine is using some special cache where the value for Yoast title is reverted back or overridden each day.

Best regards,
Jamal

June 26, 2019 at 4:03 pm #4093999

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

As your primary language is English, I also set the setting in the attached screen in WPML->Theme&plugins localization.

Best regards,
Jamal

June 27, 2019 at 4:51 am #4096595

orenK-3

Good morning Jamal,

Changed again to French and also both translation needs update:
hidden link

June 27, 2019 at 8:56 am #4098137

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hi,

Yes, it has changed to French for the title that I have edited. This, as you have said, may be related to the other issue. The translation does not get saved correctly. See this screencast, I translated the title and then refreshed/researched and the title is not translated again.
hidden link

Please see my previous private message(JUNE 27, 2019 AT 8:55 AM). I have added instructions on how to migrate your website to our infrastructure, this way we can confirm/exclude a server issue. And it will be closer to our developers if needed.

Best regards,
Jamal

June 30, 2019 at 5:27 am #4113405

orenK-3

Any chance to solve it without migrate?

June 30, 2019 at 7:19 am #4113579

orenK-3

Hi Jamal,

I made the migration.
Can you check the issue please? 🙂

July 2, 2019 at 5:47 am #4124155

orenK-3

Hi,

Jamal are you checking it?

July 2, 2019 at 11:59 am #4126527

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

My apologies for the late reply. If you login to the migrated site, you will notice that the second issue (String Translation not saving) is not present. This seconds my doubts about caching in your server.
Would you please check this with WPEngine Support, explain that your staging site is not saving the strings and a copy of a copy of it on our server is saving strings.
Maybe they can tell us about something they are using we can consider. Or there is a process that is still running and should be restarted.

Best regards,
Jamal