Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by Shekhar Bhandari 2 years ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
November 25, 2019 at 1:20 pm

andersonS

This issue is on our server because of WPML. It's dropping website speed a lot, without WPML site is loading up in less than 3 seconds, with it active, speed drops from 2-3 seconds to 13 - 34 seconds all the time. Tried all methods suggested but nothing helps.

November 26, 2019 at 1:41 am #5017713

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

I understand you are having site performance issues. Since performance issues depend upon the site, the server, plugins used and furthermore. I would need your help to narrow down the issue. Could you please provide feedback on the following questions as much as possible?

#1
We recently released new versions of WPML plugins with improvements and fixes. Being so, may I kindly ask you to update the plugin to the latest version, it would also be nice if you can check the problem with the latest version and share with us the results.

BACKUP NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

#2
Can you please review the following articles and see if all the relevant steps are covered?
https://wpml.org/faq/prevent-performance-issues-with-wpml/
https://wpml.org/2012/01/can-your-site-run-faster/

#3
Try disabling and re-enabling all WPML plugins and then going to WPML > Support > Troubleshooting and press the "Recreate ST cache tables" button.

The first visit after the re-activation of the plugins is kinda slow, but after the regeneration of the tables - it will be better.

#4
What type of hosting do you have? Shared, VPS, Dedicated, etc?

#5
Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

Thank you for helping us pinpoint the issue. Feel free to add any further information you may have.

Look forward to your reply.

Thanks

November 26, 2019 at 8:33 am #5019111

andersonS

Still the same. It's even worse. We have backups but only restoring the site works.

Also, can we edit this page on forum so it's private? There is important info we missed but added it in here... ( names od db, etc. )

November 26, 2019 at 8:37 am
November 26, 2019 at 8:39 am #5019117

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Did you performed all those test?

Can you provide feedback on this?
What type of hosting do you have? Shared, VPS, Dedicated, etc?

You mentioned "only restoring the site works." do you mean after the recent update it's even worse?

Look forward to your reply.

Thanks

November 26, 2019 at 8:43 am #5019147

andersonS

After update it's all the same, sites also a lot slower.
It's unbreable. It started acting like that from several weeks ago after updates.

November 26, 2019 at 8:57 am #5019259

andersonS

REST API is disabled, blocking some features of WPML
It looks like the WordPress REST API is disabled on this site. This blocks some features of WordPress itself and of WPML.

More info | Dismiss

This is another issue.

November 27, 2019 at 4:49 am #5025885

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

For the rest api issue, can you please use the solution provided here in the errata: https://wpml.org/errata/rest-api-is-disabled-blocking-some-features-of-wpml-notice-and-performance-issues/

Also, this error can create some performance issues so check the performance after the fix and let me know how it goes.

Thanks

November 27, 2019 at 1:16 pm #5029437

andersonS

we found this in the database can you confirm it's related.

| otgs_send_compone | 2019-12-27 11:57: | 4 weeks 1 day | Non-repeating |
| nts_data | 08 | | |
+

November 28, 2019 at 4:00 am #5033235

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am not exactly sure if it's related, I would need to debug this.

Did you applied the solution for rest api? Did it improved the performance?

Look forward to your reply.

Thanks

November 28, 2019 at 8:25 am #5033833

andersonS

I did, works ok, performance bit better, but there were other issues related to performance. We have this issue as it works for 4+ weeks now, we really need to check that process. What do you need to debug this?

November 28, 2019 at 9:55 am

The topic ‘[Closed] WPML is using ALL of the RAM on the hosting, there are hundreeds of queries work’ is closed to new replies.