Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Dražen Duvnjak 9 months ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
May 26, 2020 at 2:36 pm #6220947

mikaelG-6

I am trying to: WPML is successfully registered, but still once a week when I visit Plugins->Add new->Commercial the screen changes from displaying the plugins to a nag screen about me running an un-registered version.

Link to a page where the issue can be seen: -

I expected to see: It should keep being registered, as nothing has changed...

Instead, I got: When this happened first, I removed the site from WPML.org and re-added it get new license key. And used that new key to register. And it kept working for about a week.

And my site is hidden link but I also use hidden link for the same site using your built-in feature for this, as I am serving visitors English on the last URL, but the main site is using Swedish.

May 28, 2020 at 10:55 am #6238227

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

Would you be willing to provide us with WordPress credentials so we could investigate the issue directly?

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

I marked your next reply as private so that you can safely add credentials.

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

May 28, 2020 at 1:00 pm #6239661

mikaelG-6

Hi.
I would rather not do that as it is a live site with customers visiting 24/7. Is there any other way we could find out what's going on?

May 29, 2020 at 6:53 am #6246367

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello,

can you please try the next step:

1) The installer is fetching information about renewal every 24 hours, that's might be the reason why you still saw the notice. I suggest try clicking the button Check for updates, in the w-admin> Plugins> Add new> tab Commercial.

2) Can you please installer logs from WPML>Support > troubleshooting page.

Thanks and regards,
Drazen

May 29, 2020 at 8:30 am #6247271

mikaelG-6

I hope it was the log above you meant.

And I regularly press the update button and all plugins are up to date.

May 29, 2020 at 1:48 pm #6250269

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hello,

thanks for the feedback.

Actually I would need an Installer log. Since we use it to check for key every 24h, and if fails it would say you are using an unregistered version, since the key couldn't be confirmed.

1) Go to WPML>Support>Installer Support> click on Check Now.
- Share screenshot and all Installer log text from the bellow section. Please check my attached screenshot.

2) Check with your hosting if the following are whitelisted:

- hidden link
- hidden link
- hidden link
- hidden link

3) Check with your hosting is there anything in server logs that are blocking WPML to check the key, or some other cron job blocking it.

4) Share which hosting company you are using.

Please let me know how it goes and don't hesitate to ask if you find any problem along the way.

Regards,
Drazen

May 29, 2020 at 2:03 pm #6250369

mikaelG-6

1. Done, screenshot attached.

2. Will check with my hosting, but as I never ever had a problem before, it is highly unlikely that they suddenly is blocking those URL:s.

3. Will check this too, but find it unlikely too.

4. I am using Inleed: hidden link

May 29, 2020 at 2:36 pm #6250587

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Thanks for the reply.

It might be true, but it is better to check and confirm what hosting support says.

It would be helpful if we could access your website and check, or at least if you could provide staging site with the same issue, so we can investigate what goes wrong.

I can provide a sandbox where you can share a copy of your website, but we have had a few similar issues, and when we tested same website on our servers, the issue could not be replicated.

Please let me know how it goes.

Thanks,
Drazen

The topic ‘[Closed] WPML keeps on nagging about unregistered version once a week or so.’ is closed to new replies.