This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Itamar 2 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
July 31, 2019 at 9:15 am #4313221

kruger-hotel-group-agA

I am trying to: to add the language switch with flag..but the link is not working..I have add the custom link i.e is working good for language page..

Link to a page where the issue can be seen:hidden link

I expected to see:wpml language switch with flag working

Instead, I got: wpml langauge switch is not working

July 31, 2019 at 1:41 pm #4314835

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Currently, when I look at your site, it seems that the Language Switcher in the menu is working. When I press the Deutch language I get the German page. Please see the attached screenshot.
Have you fixed this problem already?
If so then please mark this ticket as resolved.

Thanks,
Itamar.

August 2, 2019 at 7:18 am #4327451

kruger-hotel-group-agA

I have put these link on the menu by using custom link and custom css..

can you check the language switcher by enabling it from WPML setting..adding it on menu.. "a href" link is not coming in the language switcher.

thank you.

August 4, 2019 at 2:38 pm #4336573

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the extra information.

Please fix the following on your site and check if it helps to solve the problem.
By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform that procedure and see if it help?

Thanks,
Itamar.

The topic ‘[Closed] wpml language switch on menu is not working which I have added in the menu’ is closed to new replies.