This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by janA-3 4 years ago.

Assigned support staff: Bruno.

Author Posts
September 29, 2015 at 12:56 pm #714449

janA-3

I´ve got trouble editing my Product Data in Woocommerce after installing WPML. Nothing happens, as if all fields are locked to editing. Any suggestions? A bit of a newbie but tried to follow every step of installation recommendations... Everything else seems to work just fine.

September 29, 2015 at 1:38 pm #714500

karlL-5

I have the same problem aswell...

September 29, 2015 at 9:29 pm #714898

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

These fields are blocked by default in the second language. You must make these settings in the language you created the product. The title translation, description translation, etc, you should do it on the WPML > WooCommerce Multilingual > Products.

This is important because these fields will be synchronized between translation and default product, such as the product in stock. That is, you can translate the product title, product description and some other fields that is available for translation on the WPML > WooCommerce Multilingual > Products (tab).

You can read the step by step in our documentation: https://wpml.org/documentation/related-projects/woocommerce-multilingual/#products

Please let me know if you are satisfied with my answer and if I can help you with any other questions you might have.

Thank you.

September 30, 2015 at 6:58 am #715016

janA-3

Hi Bruno,
To be more precise about my issue. Those things i can do. Problem is i can´t add any new information or change information because all "Product Data" options are locked. Lets say i want to change the product to a variable product (Note, i haven´t even created a translation yet. Meaning the product is still in only one language), byt when i do that from the drop down meny "Product Data" - change from Simple Product to "Variable Product" - nothing happens. Or if i click on Attributes or linked products - nothing happens, and so on.
Hope that explains moor of the issue.

I have tried to turned off every other plugin but it seems like the WPML is causing this. Site is pretty basic without any heavy customised code. Premium WP-theme. WP and all plugins up to date.

Is there any way you guys could have a look at/test it on the live site?

September 30, 2015 at 1:50 pm #715402

janA-3

Any suggestions what to do with this?

September 30, 2015 at 1:53 pm #715404

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sorry for the delay.

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Please let me know exactly what steps should I follow to see the problem.

Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 30, 2015 at 10:20 pm #715760

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

You say about this tabs, that you can not change (for example, change for the tab "Inventory").

I saw that this appears to be incompatibility between Visual Composer and WPML. Please, could you disable the Visual Composer and test?

If this resolves the problem, please, could you update the Visual Composer to latest version and check if the error persists?

Thank you.

October 1, 2015 at 7:10 am #715852

janA-3

Hi B, you are the best!
I didn´t update VC (Because it comes with my premium Wp-theme and i couldn´t see any fixes för WPML in the latest log). Anyhow your answer gave me hint of where to look. The answer is/was to turn enable/turn off "Pruducts" under general settings in VC. See attached screenshot. That resolved it, since you hardly need VC when you work with products meening this can stay unchecked. Thanks a lot!